Skip to Content
avatar image
Former Member

WF Transport problem - SAP generated includes

Hi all,

I have transported our inhouse WF from the Dev. system to the Test system. I have got the error message, that several includes are not found.

After checking the issue and some internet retrieval  I have got the hint, that the workflow builder creates some code and screens in a dedicated function group, named here ZWS91200013 (acc. to our Workflow).

This function group has been transported (by the general way), however when I looked into the destination folder, the respective individual Include files ....0001 to ...0007 have not been transported, whereas the TOP-Include and the UXX have been. From that the error message will come.

Somebody has written that this SAP generated code and screens are used only during development of the workflow. I also think, I don't need them anyway for the production system. Now my question:

Is there a - regular - way to 'remove' these additional includes and screens?

Note: Deleting the function group alone does not help as there are (hidden) links in the SAP generated WF software.

Any hints are welcome   Best Regards Johann

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Jan 14, 2015 at 09:07 AM

    Hi Johann,

    The same thing happend to me long back. Actually in your workflow , you might have created Forms ( Module pool form ) as a workitem interface and then later you must have removed that.( Or may be still using ). By default , when you create form for a workitem , workflow create a module pool program with the name of the workflow template ( ZWS9XXXX) and create all the includes etc. So , now you need to carefully delete in the dev system , all the traces of this Z include. In my case , i had to create a new task for that particular case and then only it left the references of Z function group.

    Please check and let me know if you have more query. Thanks

    Rakesh

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello Rakesh,

      We have the same Issue in one of our workflows. Can you tell me how i can delete the references to the z.... Includes?

      Regards

      Florian

  • avatar image
    Former Member
    Jan 14, 2015 at 08:30 AM

    I have never seen something like this. The workflow should not generate any Z-function groups?

    Could you possibly ask an experienced ABAP coder to take a look what this function group and the functions are? Maybe there is a logical explanation (someone generated the objects)?

    Aren't the "include files" 0001 to 0007 function modules (can you open the function group in SE80 to see the possible functions)? Are they activated?

    Regards,

    Karri

    Add comment
    10|10000 characters needed characters exceeded