Skip to Content
avatar image
Former Member

Sybase ASE - Cannot change parameter to start DB

Hi,

We are facing an issue while trying to start our Sybase ASE database running on Windows 2012. This is after we had to take a reboot of the server and the application/DB were stopped correctly.

The corresponding SQL service Sybase SQLServer_<SID> is not running even after trying manually.

The ASE <SID>.log file has the following information.
----------------------------------------------------
kernel libomni1 - Component Integration Services: using 'Sybase Client-Library/15.7/P-EBF23553 SP132/X64/BUILD1570-046/OPT/Sun Nov 02 11:18:33 2014'

kernel Cannot allocate shared memory as 'max memory' limit of '3398304' pages has been reached. Please increase configuration parameter 'max memory' to allow additional shared memory allocation. Total physical memory allocated so far '3398304' pages.

server  Configuration of the cache (default data cache) failed since the defined cache configuration consumes more memory than is available for buffer caches.

server  Invalid Configuration: Unable to start Adaptive Server. The server may be started with a default configuration using the -c startserver option.

------------------------------------------------------------------------------


Tried starting the DB using -c startserver, but that doesnt work.

Logs:

------------------------------------------------------------------------------
D:\sybase\SED\ASE-15_0\install>RUN_SED.bat -c startserver

D:\sybase\SED\ASE-15_0\install>rem

D:\sybase\SED\ASE-15_0\install>rem Adaptive Server Information:

D:\sybase\SED\ASE-15_0\install>rem  name:                          SED

D:\sybase\SED\ASE-15_0\install>rem  master device:                

D:\sybase\SED\sybsystem\master.dat

D:\sybase\SED\ASE-15_0\install>rem  server page size:              16384

D:\sybase\SED\ASE-15_0\install>rem  master device size:            400

D:\sybase\SED\ASE-15_0\install>rem  errorlog:                     

D:\sybase\SED\ASE-15_0\install\SED.log

D:\sybase\SED\ASE-15_0\install>rem  interfaces:                    D:\sybase\SED\ini

D:\sybase\SED\ASE-15_0\install>rem

D:\sybase\SED\ASE-15_0\install>"D:\sybase\SED\ASE-15_0\bin\sqlsrvr.exe" -d"D:\sy

base\SED\sybsystem\master.dat" -sSED -e"D:\sybase\SED\ASE-15_0\install\SED.log"

-i"D:\sybase\SED\ini" -M"D:\sybase\SED\ASE-15_0"

00:0000:00000:00000:2015/01/14 12:36:15.92 kernel  kcinit: couldn't open error l

og file 1'D:\sybase\SED\ASE-15_0\install\SED.log'.

00:0000:00000:00000:2015/01/14 12:36:15.92 kernel  Failed to log the current mes

sage in the Windows NT event log
------------------------------------------------------------------------------

The problem is that since database is down, we cannot login to isql to change the parameters. We even tried modifying the <SID>.cfg file manually  and restarting DB to update the parameter, but didn't help. The <SID>.log file is not updated after restart.

How to change the database parameter when sybase database is down? Any other way to start the database?

The problem is similar to the one mentioned in the following thread:

http://scn.sap.com/thread/3633956

Would appreciate your inputs.

Regards,

Varun

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Jan 14, 2015 at 09:29 AM

    You can change quite a few of the configuration parameters by editing the dataserver's <SID>.cfg file (look under D:\sybase\SED, or possibly D:\sybase\SED\ASE-15_0).


    As to what configuration parameter to change ...


    - if you've got enough memory on the machine you could try bumping up 'max memory' until the dataserver will start


    - if running low on memory you would likely need to reduce 'max memory'; this in turn would require that you also reduce some of the memory-related config parameters as they obtain their memory from the 'max memory' pool (eg, reduce default data cache size, reduce procedure cache size)


    - if you made any config changes prior to shutting down ASE ... consider rolling back those changes


    ---------------


    I'd probably also want to make sure I didn't have any rogue processes running on the machine that are taking up 'too much' memory (thus starving the dataserver of the memory it wants).

    Add comment
    10|10000 characters needed characters exceeded

    • Nothing showed up in the SED.log file?  Hmmmm ... very confusing ... any messages in the Windows event log?

      How are you starting the dataserver? as a service? or via the runserver file (eg, SED.bat)?

      If using the runserver batch file, have you made sure you first sourced the D:\sybase\SED\SYBASE.bat file?

  • Jan 14, 2015 at 01:03 PM

    Hello,

    you have set max memory to 5242880, this will be 10485760 KB (or 10 GB). When I check the last error log you have uploaded then I can see that the ASE isn't able to allocate the max memory:

    00:0000:00000:00000:2015/01/14 09:30:58.08 kernel  Allocating a shared memory segment of size 1352794112 bytes.

    00:0000:00000:00000:2015/01/14 09:31:00.02 kernel  Allocating a shared memory segment of size 255918080 bytes.

    00:0000:00000:00000:2015/01/14 09:31:00.05 kernel  Allocating a shared memory segment of size 4295032832 bytes.

    00:0000:00000:00000:2015/01/14 09:31:00.14 kernel  Allocating a shared memory segment of size 1055981568 bytes.

    All together will be 6959726592 bytes (6796608 KB or 6,48 GB).

    Was this configuration working in the past ? When was the last successful start of the ASE ? Check the time stamp of this start and then compare your SED.cfg with the SED.<number> file that has a similar time stamp.

    Hope this will help.

    Regards

    Stefan

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi All,

      Thank you all for the valuable inputs.

      I managed to fix this by stopping SAP and DB, took backup of <SID>.cfg file and renamed the <SID>.log file since nothing was been written to this file. This ensured a new log file is created during next startup.

      Next, I used one of the old cfg files and bumped up max memory parameters and scaled down procedure cache size parameter to create a new <SID>.cfg files

      Was then able to start the DB and application successfully.


      Regards,

      Varun

  • Jan 29, 2015 at 04:54 PM

    Hi Varun,

    I have the same issue here and it looks like a bug to me. If you decrease the procedure cache size

    you might be able to start Sybase with a particular "max memory". But if you try to increase the "default data cache" by the same amount you decrease the procedure cache before, Sybase won't come up anymore. I notices that there is an upper limit of 2.3 GB for the default data cache independent on the max memory. I used 10 GB max memory (12 GB RAM) but was not able to configure more than 2.3 GB default data cache. This makes SAP ASE 15.7 unusable on Windows for production environments. Maybe someone else faced the same issue or opened a support case at SAP ?

    Regards,

    Mat

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 29, 2015 at 05:29 PM

    The error about not being able to open the errorlog is typically a permissions error.  When opening the "Command Prompt" utility, are you using the "run as administrator" option? (right click on the icon to select this option).

    -bret

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Pankaj K Pathak

      Pankaj,
      You missed the fine print of the line above the example...
      Redirected input is NOT part of command history.


      The Sybooks/infocenter document says that this example does not work.

      Cory