Skip to Content
avatar image
Former Member

TIME dimension processing fails saying "..attribute key cannot be found.." in EPM 10

  1. After upgrading from version 7.5 to EPM 10, when we ran a ‘Full Process’ on the TIME dimension, it ran into an error saying “Errors in the OLAP storage engine: The attribute key cannot be found when processing: Table: 'dbo_tblFactCapEx', Column: 'TIMEID', Value: '20090013'. The attribute is 'Time_TIMEID'.  (1/13/2015 2:41:02 PM)”.
  2. Full error message is attached herewith – ‘Time Dimension Error.txt’
  3. After researching, we did discover that MONTHNUM needed to be converted to BASE_PERIOD. Re-processed which produced the same error.
  4. Prior to migration to version 7.5, we ran a full process on TIME dimension there. It completed successfully, confirming the issue is only with version 10.
  5. Confirmed we could see the TIMEID value of 20090013 in the following places:
    • Time Dimension in the appropriate TIMEID attribute column.
    • Confirmed mbrTIME table had base member ID with TIMEID attribute filled out correctly.
    • Data in tblFactFINANCE could be pulled using that TIMEID
  6. We truncated all the records in all the fact tables associated to this TIME dimension.
  7. Eventually, when none of the tables had any records, the TIME dimension then processed successfully.
  8. We this began to suspect the issue may not really be related to bad records.
  9. We conducted one more test to confirm this.
  10. Using an input form in EPM 10, we manually entered data in one of the models (at this point none of the fact tables have any records)
  11. Ran Full Optimize on that model with Compress Database and Index Defragmentation checked – This step failed with the error attached in ‘MatrixRateFullOptimize.txt’
  12. Ran Full process on Time Dimension – Failed indicating issue with TimeID 2012001 (that’s my manual entry). Attached error report ‘TimeDim Error MatrixRate.txt’
  13. At this point, the table only contains the manually entered records (no suspected bad records)
  14. We then suspected there could have been an issue with the upgrade process.
  15. So we reprocessed all the dimension and optimized all the models in version 7.5, made a new backup and restored it to version 10.
  16. The issue still persisted!
  17. At this point, we have tried all the possibilities we could think of. Each time the fact table is populated with records, the TIME dimension process fails indicating ‘the attribute key’ cannot be found.
  18. There is probably something in the OLAP partition that is not able to link the dimension attributes to the cubes.

Additional Information:

  1. Please find attached the existing Time Dimension – TimeDimensionMembers.xlxs
  2. Version of Excel used: Excel 2007, SP3 MSO (12.0.6683.5000)
  3. System Specs: Please see screenshot below.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    avatar image
    Former Member
    Jan 19, 2015 at 10:34 PM

    Thank you all for responding! This issue is resolved.

    Here’s what the issue was:

    • The time structure is TOTAL >> Years >> Quarters >> Months (e.g. T.ALL >> 2012.TOTAL >> 2012.Q1 >> 2012.P01)
    • As shown in the screenshot below, the LEVEL for ‘T.ALL’ member was set to YEAR, which is incorrect (we can’t have Year rolling up to a Year)

    • We changed the LEVEL to ‘TOTAL’ and this fixed the issue!!
    • If only it gave a better error message than the “..attribute key not found” message 😊

    TimeDim.jpg (58.3 kB)
    Add comment
    10|10000 characters needed characters exceeded

    • Hi Nikhita,

      good that you found the solution now please close the thread marking the "correct answer" (also your answer could be marked as correct) and eventually helpful answers.

      Regards

           Roberto

  • Jan 14, 2015 at 06:01 AM

    Hi Nikitha,

    Kindly go through the following link

    Shrikant

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 14, 2015 at 01:19 PM

    Hi Nikitha,

    1) this error indicates that there is an invalid member in the fact tables

    Have you tried doing a modify application with "process application" on 7.5 version? It works?
    In your "MatrixRateFullOptimize.txt" the message contains Log ID = 354, can you please share the full description of this log?

    Can you please share your TIME dim of 7.5 and 10 version?

    which sp of BPC?

    Regards

         Roberto

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 15, 2015 at 08:17 PM

    I had a similar issue which seemed to be the Time dimension was "out of sync" with one of my dimensions, in my case the rate dimension. Have you tried processing all your dimensions to find any corrupted records? Repair the records and then try processing the time dimension. That fixed it for me.

    Add comment
    10|10000 characters needed characters exceeded