Skip to Content

BEx Date variable doesn’t show calendar in webi prompt

A bex query based of a Multiprovider has a date variable that prompts the user to enter date in calendar format.  This is working as expected in BEx Analyzer.  But when the report is run via webi which is based on a universe (.unv), the webi shows List of values (LOV) instead of a calendar format.

The BEx variable is based on 0Date.  Data type is DATS.

The variable comes through the universe (.unv) as a dimension that’s in italics.  It has the following properties:

Type: Character      ( changing this to DATE also not working)

Primary key: Character

‘Associate a list of values’ under properties is checked.   Unchecking it gives an error on webi report on run time.

Any ideas how to get this fixed.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Jan 13, 2015 at 08:12 PM

    Hi Ramil,

           Since you have a BEx query as a source, I request you to try "BICS" connectivity from the WebI side to connect to your query.

    I am very sure that for BICS connectivity, you will be able to see the calendar prompt for your date variable.

    Please try this and let me know if your issue is resolved or not.

    Regards,

    Balajee SK

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 14, 2015 at 04:06 AM

    Hi Ramil,

    It's a known bug with BO.

    Universe ->Filters ->Select Prompt ->Change data type in @prompt, from A to D .

    Add comment
    10|10000 characters needed characters exceeded

    • Launch Universe, Select Filters pane,

      Select filter under Date object

      It should be similar to

      <FILTER KEY="[MV_DATE]"><CONDITION OPERATORCONDITION="Equal"><CONSTANT TECH_NAME="@Prompt('Date','D',,mono,free)"/></CONDITION></FILTER>

      Data type of prompt should be 'D' .Remove Class/Object entry.