Skip to Content
avatar image
Former Member

'Include....001' not found by SAP main program after transport

Hi all,

I have developed a workflow application for our inhouse administration. During the workflow development, the workflow Builder (I suppose so) has created some screens and PBO/PAI modules, which it has placed into a function pool named 'SAPLZWS91200013' (according to the workflow ID).

I have transported all the staff from the Dev. system to our test system, and have got the following error message:

>>> Program SAPLZWS91200013: Syntax error in line 000015

>>> INCLUDE report 'ZWS912000130001' not found

So it seems, that the main program does not recognize the Include, although present in the respective folder.

In more detail: The 'Main program' (of the function pool) SAPLZWS91200013 is:

1*******************************************************************

2*   System-defined Include-files.                                 *

3*******************************************************************

4  include lzws91200013top.                   " Global Data

5  include lzws91200013uxx.                   " Function Modules6

6

7*******************************************************************

8*   User-defined Include-files (if necessary).                    *

9*******************************************************************

10* INCLUDE LZWS91200013F...                   " Subroutines

11* INCLUDE LZWS91200013O...                   " PBO-Modules

12* INCLUDE LZWS91200013I...                   " PAI-Modules

13* INCLUDE LZWS91200013E...                   " Events

14* INCLUDE LZWS91200013P...                   " Local class implement.

15  include zws912000130001.

16  include zws912000130002.

17  include zws912000130003.

18  include zws912000130004.

19  include zws912000130005.

20  include zws912000130006.

21  include zws912000130007.

The Folder 'Includes' of that function pool really contains that routine 'zws912000130001', so I have no idea, why the main program does not recognise it. Even when I have re-opened, syntax-checked and activated that function pool again, after an additional transport it shows the same error.

Thanks for any comments and ideas,  Regards Johann

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    Jan 15, 2015 at 08:16 AM

    Thank you all,

    I have transported the objects individually and it worked.

    Many Thanks    Johann

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 13, 2015 at 11:28 AM

    Hi Johann,

    I think you're misinterpreting the folder structure, the INCLUDE will appear in the folder for the function group solely on the face it is listed in the function group, not that it actually exists.

    For example;

    I've added an include to the function group, it shows on the folder list, but it doesn't exist and the function group fails the syntax check.

    My guess here is the program ZWS912000130001 in your case hasn't been transported, but I'm not sure I can help you with why that is the case.

    Regards,

    Nick


    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thank you Nick for your good suggestion,

      I have checked that and I have seen: The TOP Include and the UXX Include are there (i.e. they have been transported to the test system), but the ZWS...001 etc. have not been transported, although present in the same function pool at the Dev. system (and being in the same transport order).

      Still to note that the syntax check and activation of the function pool at the Dev. system have been successful.

      So, I now see the problem, to transport single Include files despite the function group they are in...

      How could that be done...?!? Is it possible at all?

      Regards Johann

  • Jan 13, 2015 at 12:52 PM

    You have to manually transport those objects, for some unknown reason the developer/tool did not use standard rule for includes of a function group, so those include are independent main objects (R3TR PROG in object repository) and are not automatically transported with the function group (R3TR FUGR ZWS91200013) as would have been standard includes with name as LZWS91200013F01 (LIMU REPS) those would have been recognized as subobjects of the main object (and do not exists in object repository)

    Regards,

    Raymond

    Add comment
    10|10000 characters needed characters exceeded