Skip to Content
avatar image
Former Member

XML format issue for source structure....

Hi Experts,

I work on a interface as "File to ABAP Proxy". The incoming file is in XML format.

There is a incoming xml file to PI i did the structure same like the IB file, bt when checking the source with the test file its not coming.

(Below is from the input file)

<?xml version="1.0" encoding="ISO-8888-88"?>

<Envelope xmlns="http://asf.xxxxx">

<Sender>

<Id idOwner="EXT0">

When I try using encoding-"UTF-8">  and remove the <Envelope xmlns="http://asf.xxxxx"> the fields are in greenin Msg Mapping.


Also I tried to generate XSD using the incoming XML, but once the xsd is generated using th ALTOVA the nodes are in different orders.(change in stucture)



Can any on tell how should I go for this....

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    Jan 13, 2015 at 05:55 AM

    Hi

    Please create the XSD from the input xml and then use the same as external definition in SAP PI.

    I don't think the order of the fields in the input strcuture will have any impact on the interface.

    Thanks,

    Indrajit

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 13, 2015 at 06:32 AM

    Dear Selva,

    Its better to ask schema from Source Side ...

    There is a possibility of having  some optional fields present which may not be present in XML.

    Regards,

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 13, 2015 at 11:12 AM

    Hi Vijay,

    Please check if you are using the correct Encoding in XML.

    Seems the encoding that you have mentioned in the post is Invalid : encoding="ISO-8888-88"

    It should be either ISO-8859-1 or from the list of valid / supported Encodings (screenshot attached)

    Please check with the Sender to send valid Encoding formats.

    Regards,

    Azhar


    Add comment
    10|10000 characters needed characters exceeded