Skip to Content
avatar image
Former Member

DEL Key in Eclipse

Hello,

sometimes my DEL key stops working in AiE - is this a known issue (with an also known solution?) 😉

Kind regards

Christian

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Jan 13, 2015 at 07:10 AM

    Hello Christian,

    There was an older Eclipse bug in Helios with this behaviour, but apparently it was fixed. The only thing that comes to mind is that you might have some key bindings messed up. Go to Window -> Preferences -> General -> Keys and search of Delete ( + sort the table by the Binding column) and check what bindings you have for the Delete key. Currently I have the following bindings for the Delete key:

    You can try and disable any additional bindings (if they seem to not be useful) and see if the problem is resolved (if needed, you can restore default bindings afterwards via the Restore defaults button).

    Regards,

    Serban

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 13, 2015 at 11:10 AM

    Hi Christian,

    unfortunately, this is a known issue:

    https://bugs.eclipse.org/bugs/show_bug.cgi?id=440355

    I also encountered this problem a couple of months ago. I spent some time on it but was not able to find a way to reproduce it. Have a look at the bug report.

    Any kind of information which might help us to reproduce it is valuable. When you ran into it. Did it always appear in a certain scenario? For example, in my case I was using the refactoring tools a lot.

    I will update this thread once we have new information regarding this bug.

    cheers

    Thomas

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Thomas Alexander Ritter

      Hi Thomas,

      I have tried Mars now and my first impression is that it really feels faster. I´ve worked for a few hours now without any DEL trouble.

      Cheers

      Christian