Skip to Content
avatar image
Former Member

Delta Functionality issue for Generic Datasource

Hi,

I had enabled delta functionality for a generic datasource using time stamp.

Issue:

Scenario 1:

When I do Initialization with data transfer , the PSA is only fetching the data that is changed on the current date where as I have 880 records in my extractor.

The delta is also not showing up in RSA7.

Scenario 2:

If I run Full update, the extractor fetches all the 880 records into BW.

After doing the init without data transfer and scheduling the delta I get zero records even though I created new records in ECC.

Please provide any inputs for resolving this issue.

Thanks,

Susheeth

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Jan 12, 2015 at 05:43 PM

    Hi Susheeth

    Delta pointer might be corrupted here delete the flag and Initialize it again without data transfer and set the radio button to delta and start the info package


    And you please also check Scheduler > Full Repair Request, check the Indicate Request as Repair Request, when you changing option from Initialization without data transfer to full update, so that pointer will pick the current records when you check the radio button to delta


    Let me know


    How to delete the flag:


    1) Go to scheduler

    2) Initialization Options for Source System


    Regards

    Naveen Reddy

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 12, 2015 at 04:52 PM

    Hi Susheeth,

    Can you let us know if you have kept any safety limits in your datasource? Is this datasource on custom table or standard table? Have you used FM based extraction?

    Can you try to reactivate your datasource and reinitialize again? Ideally after initialization you should be able to see the delta queue in RSA7.

    Thanks

    Amit

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hello Susheeth,

      I can briefly explain what could be the issue:

      Scenario 1:

      When I do Initialization with data transfer , the PSA is only fetching the data that is changed on the current date where as I have 880 records in my extractor.

      You might want to debug this issue

      The delta is also not showing up in RSA7.

      You will not see any records in RSA7 as generic extractors work based on pull mechanism and not on push mechanism. So when you issue a delta request the data will be selected from table directly and not from delta queue. You will only see delta in RSA7 for repeat delta i.e. after first successful delta.

      Scenario 2:

      If I run Full update, the extractor fetches all the 880 records into BW.

      After doing the init without data transfer and scheduling the delta I get zero records even though I created new records in ECC.

      Since you have 1800 seconds as upper limit so you will see your delta data only after 1800 seconds in your deltas. That means extract your delta data 30 min after you create new data.

      Please let me know if this helps.

      Regards

      Amit