Skip to Content

OS command issue in sap pi file sender channel

Hi Expert,

we have a scenario in which PI will pick file from application server and just pass it to target FTP.

As per requirement, we need to add extension as .ok in the file name.

We used below OS command for this which is placed on application server.

We are running this command before message processing so that PI picks it after extension is added.

The issue is, our sender file channel executes the OS command properly and adds the extension to file name, but it doesn't process the file.

If we skip OS command, it is processing the file.

Please share your thoughts.

Regards,

Vikram

Capture.JPG (23.4 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Jan 12, 2015 at 01:56 PM

    Hi Vikram,

    maybe is some authorization problem, like the OS command changes authorization on file.

    Fabio

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 12, 2015 at 02:47 PM

    Hi,

    I have never tried it but seen this in some thread suggesting to use the setting in communication channel as mentioned below.

    Before I show the setting you need to remove the OS command from sender channel, enable the ASMA setting for file name in sender channel.

    Now in your receiver channel also enable the ASMA settings for file name. Under Target tab in "File Name Schema" put %f%.ok

    Hope this works for you.

    Regards,

    Sarvesh

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 13, 2015 at 05:07 AM

    Hi Vikram,

    Could you paste your channel logs when you run with script so that we would be able to suggest.

    Thanks,

    Naveen    

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 14, 2015 at 07:20 AM

    Hi,

    There was a timeout error in channel.

    It is working fine now.

    Thanks for your input.

    Regards,

    Vikram

    Add comment
    10|10000 characters needed characters exceeded