Skip to Content
avatar image
Former Member

I config the sybase with ssl, but it reports errors when restarting. please help.

00:0002:00000:00011:2015/01/08 14:20:23.56 kernel server will listen on all networks present on host
00:0002:00000:00011:2015/01/08 14:20:24.36 kernel No license! Cannot enable SSL feature.
00:0002:00000:00011:2015/01/08 14:20:24.36 kernel Cannot allocate resources for listener with protocol sslnlwnsck, host WIN-S32KZPJCUAU, port 5000.
00:0002:00000:00011:2015/01/08 14:20:24.36 kernel No license! Cannot enable SSL feature.
00:0002:00000:00011:2015/01/08 14:20:24.36 kernel Cannot allocate resources for listener with protocol sslnlwnsck, host WIN-S32KZPJCUAU, port 5000.
00:0002:00000:00011:2015/01/08 14:20:24.36 kernel Cannot start any network listeners.
00:0002:00000:00011:2015/01/08 14:20:24.36 kernel ueshutdown: exiting
00:0008:00000:00000:2015/01/08 14:20:24.36 kernel Sybperf helper thread is quitting
00:0002:00000:00011:2015/01/08 14:20:24.36 kernel Enterprise java bean server is already down.
00:0000:00000:00000:2015/01/08 14:20:24.39 kernel Main thread performing final shutdown.
00:0000:00000:00000:2015/01/08 14:20:24.65 kernel Blocking call queue shutdown.
00:0000:00000:00000:2015/01/08 14:20:25.07 kernel SySAM: Checked in license for 1 ASE_CORE (2015.1231/permanent/12FE BE55 1B69 AE84).

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Jan 12, 2015 at 03:52 PM

    The error message seems to imply that you do not have the necessary license to enable SSL.

    I'm assuming you only have the ssl entry in your sql.ini file and since no security license is found said sql.ini entry fails.  Without any other sql.ini entries (yes, you can define multiple entries in sql.ini with different network:port combos) the dataserver is unable to start any network listeners and so it shuts down.

    You'll need to a) get a security license (to allow enabling ssl) or b) add a non-ssl entry to your sql.ini file.

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 12, 2015 at 08:25 PM

    Hi,

    One of two things happened you didn't add the security license in your license directory or it didn't find you certificate.

    You can check to see which options and license you have enabled. Your looking for ase_asm:
    SyBooks Online

    Or you didn't add the certificate to the right location directions are here.

    SyBooks Online

    Thanks,
    Dawn Kim

    Add comment
    10|10000 characters needed characters exceeded