Skip to Content

Integration installation failed

Recently I upgraded to SBO 9.1 PL4 and for some reason the integration service framework upgrade failed, so I uninstalled it and tried to install it again.

However this time the installation process does not seem to go through. It is stuck at the step where it checks the DB connection.

I have already removed the B1if DB from the previous install. Any suggestions?

Other solutions I've tried.

1. I've tried deleting the JVM key at HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Apache Software Foundation\Procrun 2.0\SLD\Parameters\Java

2. In HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Apache Software Foundation\Procrun 2.0 I've removed the Tomcat key

3. I've removed the Z-Gero Registry folder

4. Did not see anything that applied to me in 1618978 as there is no indication from the GUI what actually fails. At any rate, I have been able to run SBO Client with the same setup on port 1433, as well as the mobile app on my phone connecting to my server before. The SQL or firewall configurations haven't been changed.

5. Tried keying some other DB name (even MSSQL) but that gives a proper connection error. Some hint here, the text turns red immediately with the correct DB (my computer name or but if I key in a wrong instance name, then it stays blue for quite awhile before the entire red text comes out with the connection failure reason.



Message was edited by: Jay Cheah The install log shows an error like this: Loading externalized properties Exception in thread "AWT-EventQueue-0" java.lang.UnsatisfiedLinkError:[B I've attached the complete log file.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    Jan 13, 2015 at 03:21 AM

    Solved it by uninstall all versions of Java and installing the latest one (1.8.0_25) which is strange as the installer actually has a JRE bundled and extracted into the temporary install folder (one that might look like this C:\Users\JayCheah\appdata\local\temp\i1421119053\windows\resource\jre\bin that should not be reliant on the user's Java environment.

    Add comment
    10|10000 characters needed characters exceeded