Skip to Content
avatar image
Former Member

EDI X12 Conversion Problem

Hi Experts,

My scenario converts an EDI xml to EDI file using the X12Conversion Module.

In the ISA segment of the xml, I am mapping blank spaces to Authorization and Security Information to comply with the minimum length of these fields. Same goes for D_I06 and D_I07 fields.

<S_ISA>

      <D_DATAELEMENTSEPARATOR>~</D_DATAELEMENTSEPARATOR>

      <D_I01>00</D_I01>

      <D_I02>          </D_I02>

      <D_I03>00</D_I03>

      <D_I04>          </D_I04>

      <D_I05>01</D_I05>

      <D_I06>114747764CP    </D_I06>

      <D_I05_2>ZZ</D_I05_2>

     <D_I07>AMXIBAP        </D_I07>

      <D_I08>150109</D_I08>

However when the message goes through the conversion module, the blank spaces are removed. This causes an issue on the receiving side.

ISA~00~~00~~01~114747764CP~ZZ~AMXIBAP~150109~0701~U~00401~000000014~0~T~\|

I have already added the following module parameters in the conversion module of the EDI Separator receiver channel but I am still getting above result. Does anyone know if there is anything I missed?

localejbs/TPMContentAccessModule

     enable.ediAckProfile = true

     enable.edisepUsage = true

localejbs/X12ConverterModule

     tpm.enable = true

     x12.checkOfValueMinLength = true

     x12.fillUpToMinlength = true

     x12.encoding = US-ASCII

I have also used the default encoding which is ISO-8859-1.

Any help would be very much appreciated 😊

Regards,

Pao

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Jan 12, 2015 at 08:49 AM

    Are the fields mandatory on the receiver side? Perhaps avoid that?

    Or try MapWithDefault or Constant and map a value to it the receiver expects.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 12, 2015 at 03:39 PM

    Hi Dimitri,

    The fields in the ISA segment are required and I am already mapping constant blank spaces to these fields to comply with the minimum length of each.

    Would you know if there are additional module configurations needed aside from the ones I have mentioned?

    Thank you very much for your help.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 15, 2015 at 08:49 PM

    Hi,


    I don't think this is an issue of mapping. There is that x12 parameters in your TPM Agreement tab in which will automatically fill out values to minumum legth. Make sure both x12.checkOfValueMinLength and x12.fillUpToMinlength is true. You can verify that in converter tool.

    Cheers,

    R-jay

    Add comment
    10|10000 characters needed characters exceeded