Skip to Content
avatar image
Former Member

Send Smartforms by respecting Smartstyles

Hi consultants,

I am using method CRM_ISA_AUCTION_SMART_FORM of class CL_DOC_PROCESSING_CRM_ORDER to send a smartform by email. It works propertly but the email does not respect the smartstyles applied to the document.

If i evaluate the html_xstr variable or the object ls_object, I notice that the document has the styles applied, but when I received the mail, the styles are losen, even though the tables designs; the final result is a plain mail text.

I´ve activated all bc services, it doesn´t solve the problem.

I would need help to send mails with tables designs and smartstyles applied before.

Thanks above all.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Jan 09, 2015 at 11:29 AM

    Hi Daniel,

    Could you check the output options listed in :

    http://help.sap.com/saphelp_470/helpdata/en/10/6d83601ee111d5b683006094192fe3/frameset.htm

    ?

    Best regards - Christophe

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Cristophe,

      I´ve done some changes:

      • I´ve adapted the objects to SSFXMLOUTPUT type, but I think this change is not neccessary because the smartstyles are active in the object before go away the system (Picture1).

      • I´ve changed out properties as link says but I don´t get succesful result.

                        LS_OUTPUT_OPTIONS-XSFCMODE = 'X'.

                        LS_OUTPUT_OPTIONS-XSF = 'X'.

                        LS_OUTPUT_OPTIONS-XDFCMODE = SPACE.

                        LS_OUTPUT_OPTIONS-XSFFORMAT = 'X'.

                        LS_OUTPUT_OPTIONS-XSFOUTMODE = 'A'.

                        LS_OUTPUT_OPTIONS-XSFACTION = 'A'.

                        LS_OUTPUT_OPTIONS-TDARMOD = '' .

                        CLEAR LS_OUTPUT_OPTIONS-XSFOUTDEV.


      We can notice that the object contains the smartstyles and table designs, but they dissappear into the mail received.

      Thanks above all.

      Picture1.jpg (82.8 kB)
  • avatar image
    Former Member
    Jan 12, 2015 at 02:39 PM

    I would like to add that if I query the mail through SOST transaction, the mail seems to have been sent with the right format, respecting all the smartstyles applied to the document.

    Then, I guess the problem is between the sap outbox (smtp) and the input server that receive the mail.

    The formats are configured as I have seen in another thread.

    I need a logical solution that could explain this behaviour.

    Thanks for all.


    SCOT.jpg (63.3 kB)
    Add comment
    10|10000 characters needed characters exceeded