Skip to Content

how to convert special characters in pi?

Hi Expert,

Need your advise on below issue:

Scenario is R3-->MQFTE (MQ Server) ->PI->MQFTE(MQ Server)-->3rd party

We are facing issue when input flat file is having special characters in the file.Below is the screenshot of spl characters coming in the file.

But in Pi these are getting converted into different format which is not readable,we recognised that these are eastern european character and used encoding as ISO-8859-2 in Receiver channel CCSID = 912 .

Need more suggestions please.

Thanks,

Narendra.


































spl char.jpg (1.7 kB)
Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

7 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Jan 09, 2015 at 08:03 AM


    Have you checked RFC settings(SM59) for Unicode character? Try to play around it once.

    Thanks,


    2.jpg (57.4 kB)
    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 09, 2015 at 08:19 AM

    Hi Narendran,

    You can use FixValue Function in mapping, fill

    KEY= ESPAXD1A S.A. VALUE=ESPAÑA S.A.

    Regards.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 09, 2015 at 08:26 AM

    Hi Narendran,

    Hope this helps.

    Special character’s handling in PI/XI simplest ever.

    thanks and regards,

    Praveen t

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 09, 2015 at 08:36 AM

    Hi Narendran,

    Try with encoding ISO-8859-1. Or try with UTF-16.


    if not try in Sm59 in R3 -> Goto the ABAP type RFC destination pointing to XI -> under MDMDP & Unicode tab -> Change the Communication type from Non-unicode to Unicode.


    Thanks and Regards,

    Naveen

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 09, 2015 at 08:39 AM
    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 09, 2015 at 12:14 PM

    Narendran,

    Download the payload and save it with .txt extension. Open the payload with foxe or notepad++. Determine if the XML is not well-formed. Link.

    Please post the screen of payload opening with notepad++ or foxe. We can guide you further.


    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 12, 2015 at 11:21 PM

    When within PI the characters are wrong displayed, then you have to adjust the settings in sender channel. Put CCSID 912 in sender channel as well, if you are sure that this is the correct code page.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.