Skip to Content
avatar image
Former Member

# in Reports below one row

Hi All,

Here is my report output in workbook

Purchase grp Country of Pur grp Region of pur grp Subregion of pur grp Key figure

10 fe t1 t11 100

10 fe # # 20

10 se d1 d11 500

10 se # # 60

I am unable to identify why this # is coming in my report.

Thanks,

Mayur

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

6 Answers

  • Jan 09, 2015 at 08:08 AM

    Hello Mayur,

    Is this an infoset report , or is the data getting loaded from different source

    Regards

    Gajesh

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Mayur,

      1. Edit your keyfigure

      2. Add thei infoobjects Region of pur grp and Subregion of pur grp

      3. Select the two (2) infoobjects and right click to any of them

      4. Select CONSTANT SELECTION

      5. Click OK


      Just post here for any query mate..

      Regards,

      Loed

  • avatar image
    Former Member
    Jan 12, 2015 at 04:30 AM

    Hello Mayur,

    To what the experts above just described. I am trying to answer this problem on my understanding.

    Multiprovider fetching the data from the cube right.
    Cube getting data from different infoproviders right?
    If this is true then this means the different flows that are coming into Cube
    donot have all the characteristic
    like 'Region of pur grp ' ' Subregion of pur grp ' along with other characteristics.
    That is why Hash is appearing.

    If you restrict hash values then the Key Figure will disappear in the report.
    Please try to include those two characteristic at datasource level for all other flows that is
    the datasources which are bringing data for all the DSOs and then include these two
    infoobjects in those DSOs and change the transformation and map those two characteristics from all the DSOs
    to the cube.
    That can be another way for solving this problem.

    Try this it will work. 😊

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 09, 2015 at 07:36 AM

    Hi,

    Check in your base cube or dso, how the data is showing.

    If same in that, then delete the data and reload, still not resolved then restrict the # exclusion in query it self only. still need info let me know.

    Thanks & Regards,

    srinu.rapolu

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 09, 2015 at 07:46 AM

    Hi Dear,

    The data in cube is perfect.Whereas what you are suggesting is to restrict the # exclusion in query it self .That means the data will show blank at that particular row.

    My point is if the same data is showing for above row why isnt it showing for below row?

    Best,

    Mayur.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Dear Mayur,

      There could be several reasons why # is reported.

      1. Check you trasaction data within the cube there will be few records which has null values for these two fields

      2. If they field are navigational attribute of master data than check the master data.

      3. If the report is built on multiprovider that check if these two fields are enable from the correct cube for reporting.

      4. Run RSRV to check the consistency of data on the cube.

      Hope some of these scenario should help further.

  • avatar image
    Former Member
    Jan 14, 2015 at 09:39 AM

    Hi Mayur,

    This is a issue faced when you use Multiprovider and if the characterstics you select is not present in both the infoprovider's on which MP is built then '#' value appears.

    Either make sure the charac selected in MP is present in all the infoproviders under MP, else use constant selection for the characterstic in query and filter with #.

    There are number of SDN docs to explain step by step. Please check.

    Regards,

    Sankameshwar

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 14, 2015 at 10:54 AM

    Hi,

    This issue might be solved by constant selection.

    For this, you have to create new selection, drag the key field and characteristics Region of pur grp, Subregion of pur grp. In the context menu of both characteristics choose "constant selection" option.

    Thanks,

    Swapna Jain

    Add comment
    10|10000 characters needed characters exceeded