Skip to Content
avatar image
Former Member

UOM Display in OLAP - Changeable? Also what's up with that ","?

In our BEx reports the UOM is displayed on the left and not in each cell of each Key Figure, while in OLAP it instead displays within each cell.  This is quite....busy and tends to clutter up the screen, additionally if you export that to Excel it also exports the UOM.  While the User can still run calculations in Excel they still understandably prefer to NOT have the UOM repeated potentially hundreds or thousands of times. 

Is there any way to stop this from happening in OLAP, can we make it like how BEx displays?  I can see certain situations where this repeated UOM would be useful, but preferably we'd like to be given the choice how to display it.

Also while I'm at it, why is it almost impossible to tell that the comma in OLAP is actually a comma?  Almost every single person who has run OLAP the first time has asked why their are decimal places, then I say it's a comma and they stare REALLY hard at the screen and go "Wow...ok...". lol  I'm crossing my fingers that their is a way to change the font in the backend somehow? *cross fingers*

BEx:

OLAP:

BEx UOM.png (3.9 kB)
OLAP UOM.png (3.5 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    Jan 10, 2015 at 12:54 AM

    Hello Jonathan

    Unfortunately the UOM display that you have showed in AOLAP is expected behavior and there is no way within AOLAP to change this. While this style of displaying UOM is beneficial when dealing with mixed currencies (for example) I appreciate it can be cluttered if the UOM is always the same.

    (Aside, in the Properties task panel for the crosstab you could try and uncheck the option to show formatting. This will remove the UOM... but also all other server formatting and the resulting number may be even less appropriate than with the UOM being displayed).

    As for the comma character... indeed, what is up with that?? In 5 years of AOLAP no one has ever commented on the comma looking like a decimal point. Here's what I see in my default install...

    I've connected to this BW system with a German account which is why the decimals and thousand separators are transposed... but you can see there is a clear difference between both.

    I used a magnification tool to compare the aliasing effects between your screenshot and mine and the numbers in both are identical but your "comma" is definitely different to my decimal point.

    It's not possible to change the font of AOLAP unless you change the stylesheets.

    What browser and version are you using and what version of BI4 are you using? Also, what is the locale setting of both your browser and BI4 (Click on Preferences in the BI Launchpad... likely it says "Use browser locale").

    Is your data source BW? If so can you log on to SAP GUI and run transaction SU01 for the user that is used by AOLAP to connect to BW. In the "Defaults" tab check the decimal notation is what you expect it to be.

    Finally, open the Analysis OLAP Administration Guide to section 4.5 and configuring Fonts. This is used for charts and export to PDF and should definitely not impact the core product but worth checking that the fonts.xml file has specified Arial as the Universal Font.

    Regards

    Ian


    Add comment
    10|10000 characters needed characters exceeded