Skip to Content
avatar image
Former Member

Error when using RFC Accessor Lookup Service in Load Balancing Environment

Has anyone had any problems when using the RFC Accessor Lookup Service in a load balancing environment?

When I run the below code in our single server development and quality assurance environments it works fine, however when I run it in our staging environment, which has load balancing configured, it fails if both of the servers are on but if only one of the servers are on it works fine.

InputParameters inputParameters = container.getInputParameters();

Channel channel = inputParameters.getChannel(rfcChannelName);

RfcAccessor rfcAccessor = LookupService.getRfcAccessor(channel);

XmlPayload request = getXmlPayloadRequest();

XmlPayload response = rfcAccessor.call(request);

The error that we receive if both servers are on is:

Technical error when calling an adapter remotely. The HMI method with the ID process was called with an incorrect session status. The system accessor object is missing

Any ideas as to where I should start looking? We are running PI 7.11 and the code is called in the init method of the message mapping.

Thanks in advance,

Jon

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Jan 09, 2015 at 12:07 PM

    Hi Jon,

    Please check the following for similar issue if it helps:

    Have you configured the RFC CC with Load Balancing?

    Defining a System with Load Balancing - Advanced Adapter Engine - SAP Library

    Are you able to do a Ping Channel test without any errors. Refer the following OSS notes if it helps

    1954947 - Ping channel for RFC channels with enabled load balancing works incorrectly

    730870 - FAQ XI 3.0/ PI 7.0/ PI 7.1/ PI 7.11/ PI 7.2/ 7.3 RFC Adapter

    Regards,

    Azhar

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Azhar,

      Thanks for the information.  I believe that the RFC CC is set up correctly for load balancing as most of the messages do go through successfully. If I cancel a hung message the ones waiting in the queue usually go through imediatly without issue.

      I tried some of the suggestions that make sense in the first link, such as making a small change and re-saving the CC, but none of them worked.

      As we are using PI 7.11 I wasn't able to ping the channel

      I didn't see anything in the FAQ that would apply to my situation. Mind you I did skim it pretty quickly.  Was there anything in particular that you thought I should look at?

      Thanks again,

      Jon