Skip to Content
avatar image
Former Member

Hyperlinked Webi Reports in SAP BI Mobile App

Hi Everyone, i have a issue in open doc of webi reports when the webi reports are opened in SAP BI Mobile App. Our BI system is on 4.1 SP4 patch2.

So, i used a bex query to develop a webi report A. Created another webi report B again using a Bex query onle and trying to create a hyperlink from a cell in report A to B. Changed the interface to html mode and right clicked on a cell and selected linking and went through the process of selecting a document and passing the parameters from A to B.

Now here is what i have done.

1) Open the webi report A and refresh it when the prompt window opens enter some values and click ok.

2) Report refreshes fine and then click on hyprlink to open report B the report opens fine and when click on refresh symbol i can see that parameters are passed from A to B successfully.

Now i open the report in SAP BI Mobile APP.

1) Open the webi report A and click on refresh option select some values in prompts and refresh it, report A runs fine.

2) Click on the link and the report B opens but does not refresh opens a blank page.

I made sure that in the hyperlink i checked the box "Refresh on Open", while saving report B i checked the option "Refresh on Open" but still the refresh does not refresh and nothing is being passed to report B. This happens only in Mobile App. In Desktop Browser things work fine but not in Mobile App.

Any one gone through this issue and an solution for how to solve it?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Jan 16, 2015 at 09:10 AM

    Hi,

    Could you post the url which has been created by your opendoc syntax please?

    The mobile url works slightly differently from desktop, so I tend to copy an existing url from another report and modify the details to suit (iDoc ID etc), rather than using the HTML wizard.

    It should work providing you've got the correct settings in your URL for:

    sRefresh=Y

    lsS[prompt name for subreport]=[Prompt Value from main report]

    With that in mind it's best to create some variables which capture the userresponse from the main report prompts, or the dimension they're looking at.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member


      Hi Rajasekhar,

      One more suggestion-

      Just for testing purpose, can you try using an object or hardcoded value to pass the parameter value instead of UserResponse()?

      If it works now, indicates a product bug and you may want to create a support ticket with SAP.

      Else there can be some problem with syntax of the link, which we can review.

      -Regards,

      VVH