Skip to Content

Web Dispatcher ClientProtocol header not set

Hi everybody,

I am trying to configure WebDispatcher to work in the following scenario:

HTTPS -> F5 Load Balancer HTTP -> Web Dispatcher HTTP -> ABAP application servers

However, when the request gets sent to the web dispatcher and then the ABAP application server, it returns with the app server hostname and HTTP port, but the protocol for the request continues to be HTTPS.

I have added the following parameters to the Web Dispatcher's profile:

wdisp/add_client_protocol_header and wdisp/handle_webdisp_ap_header but these did not work (I tried using Fiddler and this test link http(s)://server.domain.ext:port/sap/bc/bsp/sap/system_test/test_proxy.htm) and neither of them show the parameter clientprotocol being set in the header.


I also tried to add rules to the modification handler file icm_filter_rules.txt (as follows) but it's not working either.


# Modification rules for WebDisp

# set WebDisp header

SetHeader clientProtocol https

SetHeader x-sap-webdisp-ap "http=80;https=443"

#

Do you think I'm missing something?

Any input would be highly appreciated.

Maria Sahukar

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Jan 09, 2015 at 12:27 AM

    Since HTTPS is terminated on F5 and you want to generate URLs with HTTPS that point to the F5, you need to configure HTTPURLLOC in AS ABAP.

    Add comment
    10|10000 characters needed characters exceeded