Skip to Content
avatar image
Former Member

"Select All" option doesn't work as expected in the prompt panel

Environment

Using Analysis for Office version 1.4 (1.4.8.3163 to be precise) and BI 4.1 SP02 patch 6.

Issue
Can someone confirm that when using "Add lines using filter by member" option, you cannot use the "Select All" option unless you un-check one or more of the selected values in the prompt panel?

Most of our BEx queries have a combination of mandatory and optional prompts with and without authorization variables and when selecting the list of values i always see a "# Not Assigned" value in the list of prompt values. Not sure if the # value is preventing AFO from selecting all values.BEx analyzer allows you to select all values without any issue so would like to know if this is a defect or "design feature" of Analysis Office.

Any suggestions or workarounds are appreciated!

Regards,

Praveen

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Jan 08, 2015 at 08:05 PM
    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Martin,

      I tried changing the Access Mode between Master Data and InfoProvider for the prompt values, but it didn't make any difference.

      I will open an incident with SAP to confirm.

      Thanks,

      Praveen

  • avatar image
    Former Member
    Jan 29, 2016 at 11:42 AM

    Hi Praveen,

    Just out of interest has anyone managed to get a solution to this one.  I am just evaluating version 2.2 and I noticed the same issue still appears.

    This has been frustrating our users for a significant period of time now and I am surprised it hasn't had more attention.

    thanks

    Mike

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 29, 2016 at 12:26 PM

    Hi Praveen,

    Just for your information, In AO 2.2 SP1 it's working correctlty that is, you can use Select All Member without un checking the one or more selected value.

    Thanks,

    Avinash

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thanks Avinash - we are not on SP1 yet so that would explain why the issue still occurs.

      In the process of downloading SP1 now so we can evaluate further.