Skip to Content
avatar image
Former Member

How to Upgrade objects User-security with UMT tool

Hi All,

We had installed the SAP BO 4.1,now we are planning to upgrade the BO 3.x Objects to 4.X Environment. For testing purpose we have migrated the folders and reports with objects and its dependents using UMT tool but after the migration reports and folders are upgraded but their User - Security is not getting migrated to SAP 4.1 Environment.Can you please let us know how to upgrade the objects User - Security also with users and groups using UMT tool. We did't migrated the users and groups separately.

Please Share your thoughts.

Thanks,

Rajesh

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Jan 08, 2015 at 01:09 PM

    Hi Rajesh,

    Please confirm whether you have upgraded Reports and objects along with users and groups in one go. The UMT will migrate security if reports and objects are upgraded along with users and groups.

    Please try to migrate all of them together and see if the security is migrated otherwise if the users and objects are migrated separately then the security needs to be setup manually later. Refer below documents for UMT best practices.

    BI4 Upgrade Management Tool

    http://service.sap.com/sap/support/notes/1904814

    http://service.sap.com/sap/support/notes/2050594

    Regards,

    Hrishikesh

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Rajesh,

      To ease out the concepts here.

      Report (Objects) <--{security} --> User(Objects).

      Hence Security is some thing which is abstract and migrates only when both its Objects are in place

      In the example, since the GrpA is brought along with the FolderB, it will automatically carry its relations with Folder A and hence would update it too.

      -Guru

  • avatar image
    Former Member
    Jan 08, 2015 at 05:35 PM

    Hi Rajesh

    I think SAP don't recommend to migrate security from one version to another version. It would be always be suggestible to  apply the security from the scratch

    Srikar

    Add comment
    10|10000 characters needed characters exceeded