Skip to Content
avatar image
Former Member

unassigned field symbol (data segment "-1").

Hi,

I have written following simple  code in end routine , while loading data into DSO , I am getting dump.

IF NOT <result_fields>-/BIC/ZCNTENDT IS INITIAL AND

  <result_fields>-CNTRCTTYPE NE '01'

  AND <result_fields>-/BIC/ZCNTENDT < <result_fields>-CALDAY.

MOVE 'Y' TO <RESULT_FIELDS>-/BIC/ZCONTEND.

ENDIF.

Error dump is : -

You attempted to access an unassigned field symbol

(data segment "-1").

This error may occur if

- You address a typed field symbol before it has been set with

   ASSIGN

- You address a field symbol that pointed to the line of an

   internal table that was deleted

- You address a field symbol that was previously reset using

   UNASSIGN or that pointed to a local field that no

   longer exists

- You address a global function interface, although the

   respective function module is not active - that is, is

   not in the list of active calls. The list of active calls

   can be taken from this short dump.

Any input please .....

Regards

hari

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Jan 08, 2015 at 12:34 PM

    Hi Hari,

    1. Please write a statement

    ASSIGN <result_fields> before your IF condition.

    2. When conditional check is performed with field symbol values and when no entries are found for the specified conditions, field symbol will not be assigned. Handle a else part.

    3. Check the data types as well.

    Please specify if issue is resolved.

    Regards

    Kavya S

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Kavya,

      I have got it now .

      LOOP AT RESULT_PACKAGE ASSIGNING <result_fields>.

      I have forgot to write this statement .

      Issue resolved .

      Thanks

      Hari