Skip to Content
avatar image
Former Member

Applying Number Formats

Hi,

In the properties of crosstab in components tab, we have an option "Apply Number Formats" (need to enable registry to view this option KEY_CURRENT_USER\Software\SAP\AdvancedAnalysis\Settings\NumberFormat) when we enable this option, the number formats should be applied after each navigation step. if disabled, the number formats should be set back to defaults after each navigation step. I have observed that there is no change in behavior (after refreshing or any navigation step) of number formats even when option is enabled or disabled. Observed the same behavior with "Apply Analysis Styles" as well. where default analysis styleset should be applied when refreshed.Have anyone observed this? Currently we are on Analysis for office 1.4.10.3290.

Thanks,

Satya Rajesh

numberformats.jpg (41.7 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Jan 08, 2015 at 07:04 AM

    Hi Satya,

    regarding applying styles, issue is solved in 1.4 SP10

    Please follow

    http://service.sap.com/sap/support/notes/2066269

    Uncheck option(disable) : for each navigation step Default Styles will not apply

    Check option(enable)  : default styles will get affect to crosstab

    From the above screen shot I see option "apply Analysis Style" but its actually "Apply Default Formats"(below screen shot)

    and for Number Format I do not have option in panel. even I tried to enable with setting still its not.

    you may add screenshot for Setting

    Regards,

    Subhahs


    Capture.PNG (35.6 kB)
    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thanks for your inputs subhash.

      The Process for setting the registry is shown below.

      1. In "regedit", go to HKEY_CURRENT_USER -> Software -> SAP -> AdvancedAnalysis -> Settings

      2. Under Settings create a new key with the name "NumberFormat" as shown below

      3. In "NumberFormat" create a new string value "ShowApplyNumberFormatsToggleButton" as shown below and set it to "True"

      Once this is set to True, two changes take place, "Apply Default Formats" will get modified to " Apply Analysis Styles" which is more meaningful and a new option "Apply Number Formats" will appear.

      I  have verified and found that it is working as expected. When "Apply Number Formats" is checked, Analysis number formats will be applied after each navigation step. When unchecked, Local Excel Number formats in home tab (As shown below) can be applied and will be present after every navigation step ( For example: Refresh)

      Hope this helps you to check the setting 😊

      Thanks,

      Satya Rajesh

      NF1.jpg (11.0 kB)
      NF2.jpg (15.8 kB)
      NF3.jpg (8.4 kB)
  • Jan 08, 2015 at 04:26 PM

    Hi Satya Rajesh,

    I recreated the scenario that you are and I could execute exactly as expected:

    1. Created a workbook and unchecked the "Apply Number Formats"
    2. Changed the number format and save workbook
    3. Reopened the workbook and refreshed it

    >> Works as expected. Number formats remains as my changes.

    4. Checked again "Apply Number Formats"
    5. Refresh workbook

    >> Workbook reverted to original format.

    Do you have any environment information to recreate the environment scenario?
    I could see that you are using Office 2013. Are you able to check with excel 2010?


    Kind regards,
    Diego Ferrary

    Add comment
    10|10000 characters needed characters exceeded