Skip to Content
avatar image
Former Member

ARA analysis

Hello everyone,

Our company has Access Control 10.0 SP 11. We are configuring ARA (Access Risk Analysis) and already we have created a customized rule set. During our test phase we identified an error while executing User Analysis Reports as the results show users with "no violations" but we know they must show violations.

Reviewing the rule set, we observed that the trouble occurs when there are fields set with a value "*". We believe that ARA is looking for the value "*" as a character and not as an operator. So, our doubt is: Is this the way how ARA analysis is supposed to work? Or do you know if there is a related note to fix this issue?

Greatings and thanks in advance.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Jan 08, 2015 at 02:09 PM

    Hi Teresa,

    If on the rule set you specify * on the value field, the GRC will assume you want to look for a user/role that contains a permission object with the field A with value *.

    If you want any value, you either disable the field or use $.

    Hope this helps.

    In the past I also encountered problems when running the risk analysis reports with empty criteria fields, not sure if this is applicable, but just in case. By removing the criteria's that were not relevant I was able to get the results.

    Kind regards,

    NJ

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Jesus

      Thank you very much for your time and answer. It helped us a lot.

      But now we are facing another problem with this:

      When we use "Org. Level Rules" for running our analysis, the $ works as you mentioned, but other fields different from "Org. Level" (like ACTVT), Access Control does not take the symbol $ in the same way, and we obtain "No Violation" reports.

      Only if we disable the fields as you mentioned, we can obtain any value for these fields, but the problem of this solution is that these fields do not appear in the analysis reports.

      Do you know another way to solve this problem ?

      Thanks in advance.

  • avatar image
    Former Member
    Jan 07, 2015 at 09:26 PM

    See SAP Note 1817251

    Regards

    LM

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thanks for the quick reply. We already applied the note you mention a couple months ago and the problem still there. We think the way is more like Nuno Jesus said.

      Thanks again anyway.