Skip to Content
avatar image
Former Member

Installed objects via BI Content are not activated

Hi SCN,

I am installing standard objects via BI Content (BI 7.3 BI Content 747 not patched). Now, some of the activated objects are not activated. I am trying to figure it out if this is caused by a BI Content which is not patched. Currently, I am activating infoobjects one by one so I can activate a Cube or a DSO. Will this be fixed by patching the BI Content? This is just to avoid activating infoobjects one by one, so I will not miss activating other dependent objects.

Thanks.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    Jan 12, 2015 at 07:58 AM

    In SAP BW environment we install info objects before we install other objects (eg:infocube,DSO) because these objects cannot be activated if there are any reference info objects deactivated.

    We follow the below order while activating/installing the business content:

    1) install and activate standard content info objects.

    2)install and activate standard content dsos.

    3)install and activate standard content info cubes.

    4)install and activate standard content transformations.

    As you have activated the cube /DSO,you might  have got in the log what all info objects are inactive , so you need to activate them all.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 12, 2015 at 08:55 AM

    Hi Sander,

    I haven't got to try it from a fresh box though but will it activate all objects for my chosen data flow automatically (yes, together with other dependent objects)? If yes, how come that I chose the group mode - data flow before from a DSO but it did not activate my chosen data flow objects. Isn't it supposed to activate the dso after the installation and activation of dependent objects "before" the DSO? It has the same concept for activating standard objects with group mode - Data Flow Before and Afterwards.

    Hi Revathi,

    You suggested to install info objects first, so is it best to activate info objects catalogs (with every available infoobject) first from my chosen module before installing the flow I needed? (Including other dependent info objects)

    Thanks.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Sander van Willigen

      Hi Sander,

      Apparently, activation of other info objects worked.

      Thanks for the insight this will be a great help to others starting to learn the basics of the BI Content.

      Cheers!

  • Jan 11, 2015 at 09:04 AM

    Hi,

    When installing Business Content you have to choose the appropriate Grouping mode and Collection mode. I don't know what you are using here but I suggest to choose:

    • Grouping mode: Data Flow Before and Afterwards;
    • Collection mode: Collect Automatically.

    Moreover, I find it convenient to choose Display mode List. This way the objects are grouped by object type.

    Best regards,

    Sander

    Add comment
    10|10000 characters needed characters exceeded