Skip to Content
avatar image
Former Member

# is coming on variable screen

Hi All,

I have a department variable which is having values like #, cargo , it, etc....

But client is asking that when he is doing f4 on department variable it should not show the '#' value.

In Master data and info provider we are having # value for department.

Kindly suggest how to resolve this.

Thanks,

Naveen

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    Jan 07, 2015 at 09:09 PM

    Hi Naveen

    We can achieve this requirement using BADI enhancement RSR_VARIABLE_F4_RESTRICT_BADI

    Please go through the link.

    RSR_VARIABLE_F4_RESTRICT_BADI - With Compounding Object Restrictions

    Thank you,

    Nanda

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Nanda Anantha

      Hi Nanda,

      Thanks for your help

      I have copied the code and I have done some changes, now it's working perfectly as user expected.

      Thanks,

      Naveen

  • avatar image
    Former Member
    Jan 07, 2015 at 05:07 AM

    Hi Naveen,

    There are 2 ways 2 resolve this:

    1. If user doesn't want to see # entries at all, then better to delete at Infoprovider level.

    2. If it is for a particular report to avoid # entries, then in your manual entry variable "exclude #" i.e "<> (not equal to) #" in BEx Query designer.

    Hope it helps.

    Thanks,

    Shreya J


    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Shreya,

      Thanks for your reply

      1. we can't delete the # entries in infoprovider level, those values we are using in different reports.

      2. I have already excluded in filter level, but still we are facing # in variable screen for your refer

      Kindly suggest any other option.

      Capture.JPG (13.1 kB)
  • avatar image
    Former Member
    Jan 07, 2015 at 08:53 PM

    Hi Naveen,

    you can convince that this is the standard behavior and blank values are shown as # in BEx. One other option I can think of is to create auth object and give values of department other than #.

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 07, 2015 at 11:04 PM

    Hi,

    There are some serious reasons for not changing anything !!!.

    # sign is a standard way in SAP BW for displaying not assigned values.

    Changing this can cause some misunderstandings while filtering or analysing displayed data.

    All in all I think that teaching the user how to deal with # sign will be the best option.

    Regards, Leszek

    Add comment
    10|10000 characters needed characters exceeded