Skip to Content
avatar image
Former Member

XML version supported

Hi Experts,

I know this question may be very basic, but I can't seem to find documentation on it. Is the XML version 2.0 compatible with SAP PI 7.4? I'm currently working on it, but we're using XML ver. 1.0.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Jan 07, 2015 at 02:24 AM

    Yvonne,

    I think, SAP PO 7.4 supports XML version 1.0.

    SAP NetWear 7.4 does not support XML 1.1 and XML 2.0 (it seems it is not official standard yet, check Status of This Document).

    Please trigger XML with version 1.1 and 2.0 for one-to-one mapping. Let us know the result.

    <?xml version='1.0' encoding='UTF-8'?>

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Raghu,

      what does it mean when the version is called "Canonical"?

      Yes, I'll try triggering xml files with the ver 1.1 and 2.0 to see what happens. Thanks.

  • Jan 07, 2015 at 02:25 AM

    >>>Is the XML version 2.0 compatible with SAP PI 7.4? I'm currently working on it, but we're using XML ver. 1.0.


    Are you sure if there is xml standard 2.0 ??  I don't see any documentation as such?

    XML - Wikipedia, the free encyclopedia


    or are you talking about xslt 2.0 ???

    Add comment
    10|10000 characters needed characters exceeded