Skip to Content
avatar image
Former Member

Filter bar and Conditional Reporting Issues

Hi All,

i have conditional formatting in my reports and the conditions are based on 1 Std deviation from the mean with 12 months of data.

Issue -

If i add DATE in the filter bar then it gives wrong results  but if i right click and set date filter on the particular graph then it works perfectly. Is there any way to deal with this issues? Any alternate route?

Thanks,

Akshay

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Jan 08, 2015 at 12:24 AM

    For a detailed Description of the Issue-

    I am using WebI 4.1. Alerter would sound perfect because i am using it as an alert system. šŸ˜Š
    objective - Is to highlight the number for a specific day (Dec 29th) higher than the average for a day (Average of data worth 12 months).

    I have data for the past 12 months and i created a new measure "average" using calculation. Now i use that average in the conditional formatting rule.

    E.g - 'revenue amount' >= "Average revenue"
    It works perfect if right click the table and add filter to just the table. But when i add a 'filter bar' the filter gets applied to the average too and thus completely changes the rule.

    Since i created an average of 12 months of data and my filter bar is of One day at a time.

    E.g. Date - Dec 28th 2014

    But i need to make the report interactive and so filter bar is important.

    i already have applied ranking.
    My hierarchy is as follows
    State -> City

    So ranked the top 10 cities in the State.

    i tried adding 'IN([Date]) operator to the Average in the conditional formatting rule as well as in the calculations. But it completely changes the values of the average.

    Add comment
    10|10000 characters needed characters exceeded