Skip to Content
author's profile photo Former Member
Former Member

Aggregation node not aggregating

I have inserted an aggregation node below the final aggregation node in a graphical CV (see picture below). Both aggregation nodes are identical and both contain an integer field 'FLAG' which has been propagated from node 'Union_1' below and defined as a 'measure' in the semantic node..

For some unexplicable reason the records and thereby the measure FLAG is not aggregated in the first aggregation node ('Aggregation_1). Aggregation only takes place in the final aggregation node ('Aggregation'). Well darn me if I am stupid to assume that an aggregation node is supposed to ... yes exactly: to aggregate 😊

I would be most grateful if somebody could explain this most awkward behaviour to me.

I assume I am doing something wrong so I would indeed like to know what it is.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Best Answer
    Posted on Jan 19, 2015 at 12:46 PM

    Hi Me,

    In order to aggregate a measure, first you need to add it as aggregated output by right clicking the field on which you need to perform aggregation. See the image below

    \

    Once you have added it as aggregated column, your fields will be aggregated. If you have already done this and still facing issues, then please share the screenshots of aggregation nodes.

    Regards,

    Safiyu


    Untitled.jpg (53.0 kB)
    Add a comment
    10|10000 characters needed characters exceeded

    • vishal jadhav safiyudeen Vattaparambil

      Hi Guys.

      I am new to Hana and from SAP MII background.

      Even I was confused , why the aggregate node is not doing aggregation for output columns.

      But when added column as 'Aggregated Column' , I was able to see the aggregated result set in data preview.

      Spend lot of time, but this post helped me.

      Thanks

  • author's profile photo Former Member
    Former Member
    Posted on Jan 19, 2015 at 12:36 PM

    Hi Mr Me,


    In order to aggregate data in aggregation node (in your case aggregation 1), you need to right click on "FLAG" field and select add as aggregated output. Then only in the upper level it will be aggregated otherwise, it will be only projected.

    However in the final aggregation node the measures are automatically aggregated.


    Regards,

    Sumit

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 18, 2015 at 12:12 PM

    Any ideas out there?

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.