Skip to Content

Report using BICS connection only allows default values in prompts from SAP Exit

I have a BOBJ report built off a standard BEx query that has several prompts where the variables use SAP exits to pre-fill the prompt values. One of these is "Controlling Area" and another is "Fiscal Year/Period" and lastly "Access Method" which allows the user to choose replicated data in a cube or direct access via a virtual cube. When I run the BEx query I can change the values from these pre-filled defaults without issue by selecting from a list of all possible values. Previously I could do the same in the BOBJ report but now when I run the report the only options I have to select from are the pre-filled defaults from the SAP exit. I've tried purging the data and prompt values in the report and creating a new report off the same BEx query but get the same results. I'm not sure if this is related to the patch version of BOBJ (4.1 SP4 P2) or BW (7.4 SP9)? We recently went from SP8 to SP9 in BW but I haven't read anything about this being an issue in SP9.

Edit: added a picture showing the comparison between the available BEx prompt values and BOBJ prompt values for Controlling Area.

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

7 Answers

  • Best Answer
    avatar image
    Former Member
    Jan 27, 2015 at 03:57 PM

    Hello Chris,

    You can try your luck by implementing the note:

    2068075 - BICS: Values of exit variables remain empty after refresh

    Thanks,

    Hari Venkatesh

    Add comment
    10|10000 characters needed characters exceeded

  • Mar 10, 2015 at 01:57 PM

    Hi Chris,

    We are having a very similar issue.

    We upgraded to BI 4.1 Sp5 patch 1. We didn't have this problem. (We did have other issues)

    But now we just upgraded to BW 7.4 sp09 and we have this issue.

    Whenever we run the Webi in HTML Viewer mode and click refresh on the required prompts,

    We only get the values that were put in as default. Also, if we click cancel in the prompt box then click refresh again, the LOVs do populate as expected.

    One interesting fact is that while this occurs on most reports, there are a couple that don't seem to have the issue.

    We haven't been able to determine what is different on these reports yet.

    We have opened a ticket with SAP.


    Thanks

    Dick

    Add comment
    10|10000 characters needed characters exceeded

    • This sounds almost exactly like our situation. I haven't tried cancelling and re-opening the prompts but I'll give that a try next time I'm in the system. Please keep us updated with SAP's recommendations - it seems to be related to BW 7.4 SP9 since we didn't have these issues before moving to this patch level.

      Incidentally we're also experiencing issues with some of our direct access dataflows after moving to SP9 - see my SCN post on this:

  • Mar 10, 2015 at 06:53 PM

    Hi,

    We implemented the manual correction from the note mentioned above (OSS - 2107060) in our Dev system and that fixed our issue.

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 07, 2015 at 06:10 AM

    Hi Chris,

    Webi only gets values from Cube for the variable .To consider Master data values for prompt ,we need to change Infoobject properties .

    RSD1 -Infoobject - Business Explorer

    Query selection value : Values in Master data table

    http://scn.sap.com/thread/3504754

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 07, 2015 at 09:04 AM

    Hi Chris,

    If your Webi report on top of Bex query, then It's thumb rule, Webi prompt will get only values from Cube or Multi Provider.

    Actually, Webi show the master data for the prompt, you have to change Infoobject properties via RSD1 - Infoobject - Business Explorer.

    For reference see the below image.

    Cheers,

    Amrendra


    Add comment
    10|10000 characters needed characters exceeded

  • Jan 07, 2015 at 05:33 PM

    So some additional information. We found that doing a wildcard search (*) in the WebI report returns all of the values from Master Data. Previously just refreshing the LOV in WebI would do this so not sure if it's related to BW SP9 that we need to do the wildcard search in order to view the values but at least now we're able to retrieve them for selection.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 13, 2015 at 11:24 AM

    Hi everyone,

    we have the same Problem.

    It is not possible to generate a LOV in Webi.

    The same Problem also exists in Analysis for Office and Analysis for OLAP

    Environment:

    SAP BO 4.1 SP4 Patch 5

    SAP BW 7.4 SP9

    Any ideas or solutions?

    Thx

    Regards,

    Daniel

    Add comment
    10|10000 characters needed characters exceeded