Skip to Content
avatar image
Former Member

Dynamic Parameter to be passed in SWFVISU

Hi Experts

Need help on passing dynamic parameter in SWFVISU to configure a standard task TS00500003 ( Review and Completion of Initial Record) related to EHSM Incident Mgmnt.

The work item is coming in SAP inbox in portal , on clicking the required WD application is opened without any data .

Reason is the value of KEY is not getting passed into WDA, maybe due to worng parameter set in DYNPARAM in SWFVISU.

Currently it is set to KEY=${INC_ROOT_KEY} , INC_ROOT_KEY has the value of Incident KEY as seen in WF task manager log.

Need help as what exact parameter needs to be passed to DYNPARAM so that data is displayed in the WDA screen.

Thanks

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Jan 06, 2015 at 06:17 AM

    Hi Iohit,

    Are you using the UWL then?  It's not enough to put in your Dynamic Parameter... you will need to use the UWL XML Configuration to explain to the UWL that it needs to read INC_ROOT_KEY from the webflow container, as it is possible to read the parameter from the container or a BOR object, for example.

    If this is a standard task and a standard parameter then their should be a matching UWL XML Configuration file in the Portal Business Package for that task and it should be visible in the UWL Administration iview if it has been loaded up to your portal.

    Rgds,

    Jocelyn

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Jocelyn Dart

      Hi Joyceln

      As you suggested there is a standard xml file present for this task as attached below.

      And also the config from SWFVISU was removed for this task, later checked by clicking the workitem in Portal inbox on which we got below error.

      Since its a standard task and there is standard uwl.xml file present too , is there any more setting required to link the standard xml file.

      On observation we also found the systemId="SAP_ECC_EnvironmentHealthSafety" is present in xml which is not there in our portal system. Our system id = SAP_ECC_Financials. Can this be one of the issue why the standard xml file is not reached on clicking the workitem and throwing the above error.

      Waiting for your response.

      Thanks

      Lohit

      EHSM.png (102.4 kB)
      Error.png (33.3 kB)
  • avatar image
    Former Member
    Apr 15, 2015 at 07:16 AM

    Hello All,

    Issue solved by making few changes in the SystemId in the uwl.xml file.

    Thanks

    Lohit

    Add comment
    10|10000 characters needed characters exceeded