Skip to Content
avatar image
Former Member

Default Search Mode

Hello all,

Could we default search method for MDG-S. By default Address search is displayed and we want Enterprise Search to be displayed.

Any help please.

Best Regards, Srihari

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Mar 22, 2016 at 11:33 AM

    Hi Srihari,

    I know this reply is late but I wanted to put it on this thread. You can change the parameters in the UIBB customizing to adjust the default search method. I'm using HANA based search so I've include the steps below for defaulting to a HANA search method but the same could be done for Enterprise Search. Also, we are using ERP vendor UI so you will have to make some changes in navigating the UIBB for supplier UI but it is the same process.

    ERP Vendor UI

    Go to manage UI config BS_OVP_BP: BS_OVP_SP_VL > OVP: BS_SP_VL_OVP and

    create customizing then click configure for UIBB Search UIBB:

    BS_BP_DQUERY_DB_ADDRESS_ATTRIB and click general settings and then click feeder class

    parameters. Change search mode to HA and incld. search help to HANA

    search help MDG_BS_SUP_SUPPLIER

    Material

    Go to manage UI config MDG_BS_MAT_SEARCH_06 >

    MDG_BS_MAT_CLS_SEARCH_OVP_06 and create customizing then click configure

    UIBB for MDG_BS_MAT_CLS_SEARCH_05 and change the Attributes of the

    Element providerDefaults for search mode HA and the search help

    MDGM_MM_ORGS_CLF

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 12, 2015 at 04:29 PM

    Dear Srihari,

    You need to configure the MDG IMG node "Configure Duplicate Check for Entity Types" under "Search and Duplicate Check" configuration to set the default search method to be used. You need to fill the Data Model as BP, entity as BP_HEADER and set the Second Search Mode column as "ES" and then you should get Enterprise Search as default search method.

    Regards,

    Kiran

    Add comment
    10|10000 characters needed characters exceeded

    • The approach i suggested should work even for ES too. You have to put 'ES' instead of 'HA' in USMD_SEARCH_MODE field and nothing in the USMD_SEARCH_HELP field. But glad that you resolved the issue.