Skip to Content

Capture Subtotal value in Debugging

Dear All,

Can you please let me know how to get the values stored in any Subtotal in the SD pricing procedures. I need to use them downstream for my calculation in my code. I have tried with KOMP-KZWI1,KOMP-KZWI2,KOMP-KZWI3 etc. by assigning respective values in the Subtotal column. But unfortunately was unable to retrieve the same in debugging as they were returning "ZERO" value.


Would appreciate your prompt response on the same.

Regards,
Anirban

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Jan 05, 2015 at 04:07 PM

    What exactly are you trying to debug?

    Also - naturally, only the items that have something in the 'Subtotal' configuration will be transferred to the KZWIn fields. Other totals are not available in any fields, to my knowledge, and can't really be used in the ABAP code.

    Add comment
    10|10000 characters needed characters exceeded

    • But my question is still not answered - what exactly are you debugging and why?

      It doesn't seem like a far stretch to imagine that perhaps the value is filled somewhere further in the code than where you placed a breakpoint. Also how is the subtotal's value different from VBAP-NETWR?

  • Jan 05, 2015 at 06:07 AM

    Hi

    KOMP-KZWI5 or KOMP-KZWI3 is the right structure to get this information and I can see the values in debugging screen in these fields. I am not an ABAPER so I can't suggest you technically but I have just checked and its working for me.

    You should have asked this in ABAP forum so that some ABAPER could help you on this better.

    Thank$

    Add comment
    10|10000 characters needed characters exceeded

    • Hi

      This is not dependant on condition type. If you have assigned subtotal to any step it should come there in debugging mode.

      Once thing I have noted is that when I press enter after entering material, customer and quantity in sale order system goes in debug mode but doesn't show any value in subtotals. When I press F8 and go to condition tab then system again goes to debug mode and shows the values in subtotals as I have posted in my earlier thread. I don't know why. May be @Jelena Perfiljeva could help you here as she is good in ABAP and SD both.

      Thank$