Skip to Content

why mb90 dosen't work with other language ??

hi every body

our language is persian . end users for print Repeat used mb90 . 2 weeks age they can't do print . they have NDR parameter

but when I change the default of date to EN it is possible .look at these :

error message : no message for repeat processing exist

when i change it to :

please guide me .what can i do???

Capture4.JPG (56.3 kB)
Capture3.JPG (20.0 kB)
Capture.JPG (18.1 kB)
Capture.JPG (26.3 kB)
Capture.JPG (30.8 kB)
Capture.JPG (32.5 kB)
Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

11 Answers

  • Jan 04, 2015 at 12:28 PM

    Messages are stored in table NAST, table NAST has the language among the key fields.

    if you want repeat an existing message, then it has to be done under the same conditions, with the same language

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 04, 2015 at 10:17 AM

    Hi,

    May I know why you used the material doc year as 1394 in the first case?.

    Could you please check it with year as the correct year (like 2014) from MKPF (MKPF-MJAHR) and test the scenario again.

    Regards,

    AKPT

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 04, 2015 at 07:01 AM

    before 2 weeks ago it work . but now it dosen't work

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 04, 2015 at 11:48 AM

    because of our date format :

    here you are :


    Capture20.JPG (24.9 kB)
    Capture21.JPG (39.1 kB)
    Capture22.JPG (10.9 kB)
    Add comment
    10|10000 characters needed characters exceeded

  • Jan 04, 2015 at 12:19 PM

    please look at the top of the page .I said it work with format 2014

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 04, 2015 at 12:25 PM

    also in MN22 it was EN . I changed it to FA ( persian) . but still it dosen't work


    Capture10.JPG (32.1 kB)
    Add comment
    10|10000 characters needed characters exceeded

  • Jan 04, 2015 at 12:51 PM

    exactly .

    now what can I do that after this time they can print it with FA language . do i change the any setting???


    Capture17.JPG (54.1 kB)
    Add comment
    10|10000 characters needed characters exceeded

  • Jan 04, 2015 at 01:29 PM

    Mr jurgen look at this document .

    I take a report in NAST for persian language and I found this document :

    but this document also in mb90 dosen't print .


    Capture140.JPG (27.6 kB)
    1985000.JPG (50.3 kB)
    Add comment
    10|10000 characters needed characters exceeded

    • I did not say you have to change the date format, I just wanted to say that you have to enter 2014 in MB90 since this field is not maintained according to the persian calendar and has no conversion exit to display the year according to the Persian calendar.

      The date is stored in any case the way SAP designed, you user settings just make it look different.

      If you remove the flag for "use conversion exit" in the SE16 settings, then you would never see your Persian date in SE16 , no matter what setting your user profile has.

      I don't know if that is by design that the document year is not converted or a bug. You may need to contact SAP for this.

  • Jan 05, 2015 at 03:47 AM

    Dear Khojaloo,

    Have you tried to create new message output line in MB02 with Perisan language....?

    Once output created execute MB90 with processing mode 1 and try...

    Regards,

    Karna J

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 05, 2015 at 05:13 AM

    Dear Experts

    we log on to sap with EN language but the format of date is persian .

    look at this :

    it's relevant to today that convert to persian calender

    we change the date format in su3

    dose it relevant to any job or program ???may a program didn't execute???


    Capture.JPG (35.1 kB)
    Capture.JPG (78.6 kB)
    Capture.JPG (82.5 kB)
    Capture.JPG (22.5 kB)
    Add comment
    10|10000 characters needed characters exceeded