Skip to Content
author's profile photo Former Member
Former Member

SLT pointing to HANA via db tunnel throws an error during creation of configuration

Hi,

I am trying to replicate data from MS SQL database to Hana via SLT. I have configured the MS SQL database in DBCO and the connection test is successful. I have opened up a db tunnel using the HCP SDK from the SAP SLT server. Using the LTR transaction, I am trying to create a new configuration. In the HANA target details, I enter the user name as DEV_*, password as specified in the command console by sdk, host as localhost:30015. When I specify the configuration name different from NEO_* I see an error "Error opening db connection" and when I enter NEO_* as the configuration name I see an error "invalid table name: Could not find table / view RS_REPLICATION_COMPONENTS in schema SYS_REPL". I cannot see a SYS_REPL schema and I am assuming that this should be created. Any suggestions on how I can get past this error?

Thanks!

SK

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Jan 04, 2015 at 03:28 AM

    Hi SK,

    Where are you checking SYS_REPL schema?

    Best Regards

    Sachin

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 21, 2016 at 09:48 AM

    Hi Swaty,

    How do you manage opening/closing the tunnel automatically?

    I hope that it is opened only when the replication takes place?

    Regards

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.