Skip to Content
avatar image
Former Member

Getting 'processDPCommandsEx' API error while creating report in Web Intelligence BO 4.1

Hi Experts,

My Universe is designed using BO 4.1 Information Design Tool (IDT) using Multisource connection -MySQL connection.

I have two data sources in my Universe. If I create query in IDT  using objects from both data sources then it is working fine but as soon as I create report using Web Intelligence (BI Launchpad), I am getting error message- "An Internal error occurred while calling 'processDPCommandsEx' API. (Error-ERR_WIS_30270) (WIS 30270)"

I am getting the same error while creating report using Webi Rich client also with the same universe.

Has somebody experienced the same issue? Please help.

Thanks.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Jan 02, 2015 at 04:51 PM

    Hi Remi,

    When you're testing in WebI Rich Client, is it on the same machine that you have IDT installed on?  Just want to make sure the data connectivity is setup correctly since this can be the cause of the error as well.

    As Sateesh mentions, it is a fairly generic error - meaning there is an issue with the data provider and can be a number of things causing the issue.  If you search KBAs, you'll likely come up with dozens.

    I would recommend enabling logging and take a look around the error thrown in the logs to see if you can get a bit more detail around the cause and then search the KBAs or update this thread to help find a resolution.

    Thanks,

    Carly

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      the error comes from your universe

      you must check the integrity , object types ,  the SQL script , looks to the compatibility of your joints...
      running under BI LP or rich client  , u will get the same error  thats why u have to look first at your unx level

  • Jan 02, 2015 at 12:14 PM

    Hi Remi ,

    This is a generic error.

    Do you have 2 universes for the report.It may occur because of prompts merging .

    Check syntax of your prompt , validate the data type of objects which used in prompts /query.

    Below blog may helpful.

    Approaches to Error WIS 30270 troubleshooting - Business Intelligence (BusinessObjects) - SCN Wiki

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Sateesh

      I have only one universe with two data connections and no prompts are given at report level or universe level. The thing is query is working fine in IDT but not in Launchpad or Rich client.

      Thanks.