Skip to Content

Set SAPJVM startup parameter

Hello All,

I am having JVM outofmemory error & check some SAP notes , They are saying below:

The parallel / concurrent collector will throw an OutOfMemoryError if too much time is being spent in garbage collection: if more than 98%

of the total time is spent in garbage collection and less than 2% of the heap is recovered, an OutOfMemoryError will be thrown. This

feature is designed to prevent applications from running for an extended period of time while making little or no progress because the

heap is too small. If necessary, this feature can be disabled by adding the option -XX:-UseGCOverheadLimit to the command line.

---------------------

You can try to disable this default policy by simply adding this

parameter at your JVM start-up:

-XX:-UseGCOverheadLimit

But if i try to use below:

java -XX:-UseGCOverheadLimit , It is giving me error. & not taking that option.

So where should i set that parameter ? How i can i add this parameter to JVM start-up?

Please help.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Jan 02, 2015 at 01:09 AM

    Unfortunately you haven't mentioned what product you are having the problem with.

    Did you set the parameter in the Configtool? if yes based on the recommendation from which SAP note/KBA?

    Cheerio

    Reagan

    Add comment
    10|10000 characters needed characters exceeded

    • HI Joshi,

      You should set the JVM parameters using config tool.Below link gives the procedure how to connect to configtool and modify the parameters

      https://help.sap.com/saphelp_nwce10/helpdata/en/43/73949862c16fcbe10000000a1553f6/content.htm

      Regards,

      Murali