Skip to Content

JavaBE.ini on Work Manager 6.2


I have configured a wrong client ID on mi Work Manager installation, so, I went to JavaBE.ini to change it.

The problem is that if I change that value, I save it, and after restarting SMP, that goes to the previous value again.

Do you know how to change the value successfully?

Thank you in advance.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    avatar image
    Former Member
    Jan 01, 2015 at 04:00 PM

    You need to publish a new version of the app from Eclipse which contains the updated JavaBE.ini.

    Choose "Production Version", select your SMP Agentry app folder and in the middle of the dialog there is an empty field called "Publish Folder Structure" in which you can right-click and choose "Add File".

    Here select the updated JavaBE.ini file. Once you finish the Wizard, this will create a new deployment package in the Agentry app directory which you selected.

    Now go to SMP Management Cockpit -> Applications -> your app -> App specific Settings. At the top you can browse for the zip file. Once you select the zip file, the new app version including your JavaBE.ini is being deployed to the SMP server. You might need to restart the Agentry app:

    SMP Management Cockpit -> Settings -> Agentry App Restart -> select your app and click on the "Save" button.

    Add comment
    10|10000 characters needed characters exceeded

    • Thank you all!

      I deleted the app configuration from SMP Sever, and I deployed a new version of the app with the new configuration, and now the data I wanted to change it's ok.

      To try all the possibilities, I made it changing the javaBE.ini inside the .zip and it worked too. I just needed to delete the app and deploy it again, if I just change and restart, it does not work.

      Thank you!