Skip to Content

Connection Shortcut failing BO4.1 (IDT)

I have BO 4.1 SP3 and using IDT to create an ODBC connection to MS SQLServer using MSSQLServer 2012 ODBCdriver.

I can create the connection and it is also successful when testing it but when I publish it to the repository

and double-click it to open it in IDT it fails with the following message when I click on the TEST button.

And when I click on the EDIT button it comes up with a window with a TEST Connection button and when I click

this TEST button it is successful!!  Why does it fail from the first TEST button?

Also when you publish the conn to the repository it prompts you to create a shortcut and I click Yes but when I test

this shortcut it also fails.

This is the error message - [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified

To be sure Data Source name is there both on my machine and on the BO server and the connection works both on my machine

and after publishing it to the server except for the instances mentioned above.

I have tried changing the connection of the DF to the newly created shortcut I get the same error as mentioned above however when

I use the connection itself (not the shortcut) in the DF it connects.  But using the conn and not the shortcut isn't the right practice.

I am not sure if the DSN was created using use c:\windows\sysWOW64\odbcad32.exe or \system32\odbcad32.exe

but I am assuming DSN is not the issue since it does work in the situation mentioned above.

Any guidance from the experts will be appreciated.

Thanks

Abdul

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    Jan 02, 2015 at 03:00 PM

    Did you create ODBC connection in client PC also?

    Add comment
    10|10000 characters needed characters exceeded