Skip to Content
avatar image
Former Member

Calculation view throws service exception of network error.

Hi Experts,

I have one calculation view with 4 input parameters and it return one table as output.

I have consumed it in a .xsodata file. when I am exposing it with metadata as below its working fine.

xxxxxxxxxxx/TestXS.xsodata/$metadata.

but if I provide input parameters as below,

xxxxxxxxxxxxxxx/InputParams(param1='val',param2='val',param3='val',param4='val')

it throws the below exception

<message xml:lang="en-US">Service exception: [2567] network error</message>


My odata definition is below



service namespace  "XXXX"

    {

   "XXXX.DATA_MODEL::Test_Calc" as "TestXS"

    key generate local "ID"

     parameters via entity "InputParams";

    }

P.S: This URL is working fine for other colleague's system.

Please assist me for this. Thomas Jung & Krishna Tangudu

Thanks in advance.

Message was edited by: Tom Flanagan

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Jan 07, 2015 at 02:25 PM

    Hi Amba,

    For one of my colleague friend same kind of error was coming. We tried a lot and finally we decided to reset the password for the user. Then it got resolved. It seems funny. But it worked for us.

    Just try it. It may work for you. Please reply the result.

    Regards,

    Sumeet

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Sumeet,

      Thanks for your reply. I also reset my password, but still its not working.

      It seems its a problem of authorization. I assigned the authorizations again, but the issue is same.

      Regards,

      Amba Bisht.