Skip to Content
avatar image
Former Member

Crystal Reports Viewer not working

I am having an issue with Crystal Reports Viewer 11.  I have 16 PC's on my domain and CR Viewer will only work on 2 PC's.

On the other PC's I get 1 of 2 errors, the error messages are:

1. This group section cannot be printed because its condition field is non existent or invalid.

or

2. Failed to retrieve data from the database. Database Vendor Code 1301.

The PC's that work are Windows 7 64-bit and Windows XP 32-bit.  The not working PC's are a mix of Windows 7 32-bit, Windows 7 64-bit, and Windows XP 32-bit desktops.

I don't see why CR Viewer 11 works on 2 but fails on the other 14 PC's.  They are all on the domain and I have tested using the same domain account.

Thanks,

Eric

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Dec 31, 2014 at 02:24 PM

    1.  For the "Database Vendor Code" error, you need to search for the error codes for the type of database you're connecting to.  This error is passed through from the database.

    2.  The Crystal Viewer is 32-bit software.  You need to be sure that you have the 32-bit drivers for you database installed.  If you're using ODBC, you also need to make sure that you have a 32-bit ODBC connection configured, not a 64-bit connection.

    -Dell


    Add comment
    10|10000 characters needed characters exceeded

  • Jan 05, 2015 at 10:08 PM

    Check the DB client. Make sure it is the same on all computers.

    - Ludek

    Senior Support Engineer AGS Product Support, Global Support Center Canada

    Follow us on Twitter

    Add comment
    10|10000 characters needed characters exceeded