Skip to Content
P D

Not getting stopped on debugger point

Hi Experts,

     I am having an adobe form which is getting called from  SAP PLM application (webdynpro based). I am able to reach the debugger point in dev and quality with the help of generating the function module for the adobe form and putting the external debugger point. But the same way i tried in production, the debugging is not getting triggered. What will be the possible reason for this ?

BR.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    Dec 31, 2014 at 11:11 AM

    Hi Sam,

    Check your System Setting.

    Go to

    SE38->Menu->Utilities->setting->in ABAP Editor tab->Debugging tab->Put user Production User id.

    and then check with External Break-point.

    And also check, Your user id is having Debug authorization of not. (once you will enter you user id in setting, and if your user id is not having authorization for debug, a pop-up message will appear. )

    regards.

    Praveer.

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Praveen,

      Thanks for your answer. I am using a fire fighter id. So that id is being shown in the debugging user space.

      BR.

  • Dec 31, 2014 at 11:39 AM

    Go to SM51. If there is more than one application server shown, then that's the answer. You have to set an external breakpoint in the code on each application server. Which can be annoying when you've got thirty of them... 🤯

    Add comment
    10|10000 characters needed characters exceeded

    • P D Matthew Billingham

      Hi Mathew,

      SRDEBUG is a tcode. We can make external debugger active for all application server for a particular user. This is an alternative for putting break point in each server.

      BR.

  • avatar image
    Former Member
    Dec 31, 2014 at 11:13 AM

    Not the same sap user ID?
    The ID not have SAP_ALL authority in SU01?

    Interesting.

    Add comment
    10|10000 characters needed characters exceeded