Skip to Content
avatar image
Former Member

Unable to deploy Application using NWDS 7.31

Hi All ,

I am unable to deploy web dynpro java application using NWDS 7.31 in NW 7.4 Portal.

I am getting the following error screen.

i have attached the error screen shot and build.log file

Regards,

Nitesh

error.jpg (172.6 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    Dec 31, 2014 at 07:24 AM

    are u using jdk.1.7?

    if yes, please change to jdk 1.6

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Nitesh,

      Are you using windows 7?

      If yes, then please try adding JDK1.6  (JAVA_HOME) at the beginning of the Path, in the Environment variable setting.

      Do a OS Log-off and login.

      Then start the NWDS and  try deploying the application.

      This should resolve the issue.

      Regards,

      Karthika S.

  • Jan 05, 2015 at 10:36 AM

    Hi Nitesh,

    As a quick workaround, can you use the telnet tool to deploy (check SAP NOTE 1715441).

    Hope this helps.

    Thank you and have a nice day!

    _____________

    Kind Regards,

    Hemanth

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 05, 2015 at 09:50 AM

    Hi Nitesh,

    The SapNetweaverDeveloperStudio.ini file

    -vm

    C:\Program Files\Java\jdk1.6.0_07\bin\javaw.exe

    Just try up to bin only.like C:\Program Files\Java\jdk1.6.0_07\bin

    Other wise check the you jdk initialed in C drive   means.Check your system 32bit / 64 bit.

    the above path for 64 bit only.

    Other wise check this folder(C:\Program Files (x86)) java is available.Available means use this path.

    C:\Program Files (x86)\Java\jdk1.6.0_07\bin

    Regards,

    Durga Rao V.

    Add comment
    10|10000 characters needed characters exceeded

    • Hi

      JAVA_HOME does not count here.

      Other environment variables like PATH does not count either i.e. java -version can be misleading too.

      What counts as others mentioned previously is the -vm parameter in the ini file. However often mistyping this parameter (due to whitespace in path and other typos) often the parameter is ignored.

      I can suggest this hint: delete the -vm parameter (as well as the next line if the path to javaw.exe is in the next line) and restart nwds. This case nwds will prompt you to browse the javaw.exe. Make sure you browse for a 32bit jdk1.6 one. If the jdk you browse for is not in the x86 version of the program files then you use a not supported 64bit version. JRE is not supported eiher.

      Cheers

      Ervin