Skip to Content

Delay in Ack messages

Hi Everyone,

We are using a scenario in which third party tool is sending 1000 material records to be created to ECC through PI (SOAP adapter used with QoS: EOIO) and ECC is sending Acknowledgement msgs back to the tool again through PI(XI Adapter).

As we are using SOAP Adapter with EOIO Quality of Service but still some messages are getting sent at the same time (which should be one after the other).

Can anyone advice what else can be the solution??

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Dec 31, 2014 at 02:09 PM

    >>>As we are using SOAP Adapter with EOIO Quality of Service but still some messages are getting sent at the same time (which should be one after the other).

    Did you validate the quality of service in ECC to see if it is EOIO ? You can find it in sxmb_moni.

    Also enable "maintain order runtime" checkbox under interface determination(receiver interface tab) and see if it helps.

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 01, 2015 at 09:26 PM

    Aayush,

    How it was determined that messages reached SAP ECC at same time?

    Please trigger multiple messages from source system and check queue (defined in EOIO). Check queue depth in SAP PI.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 02, 2015 at 12:15 PM

    Hi Aayush,

    Are you sure that message in ECC are reaching at same.Because since you are using soap adapter and PI is picking message one at a time,so there has to be some diff may be some seconds.

    Then PI will take time processing the message.

    i would suggest you take time from sxi_monitor of PI and see when message came and left PI.

    And same information you take from ECC.

    then you will be able to find the exact time diff.

    And secondly you are sending ack i think via proxy,it will  also send one msg at a time.so again there will be some time diff

    Regards

    Naveen

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 02, 2015 at 01:59 PM

    Thanks everyone for your replies .....

    I have resolved the problem by myself, using a bpm in the interface !!

    Regards,

    Aayush

    Add comment
    10|10000 characters needed characters exceeded