Skip to Content
avatar image
Former Member

How do I turn off WebI animations?

Is there a way to turn off the animations in WebI in places like the Format Chart window?  The last time I opened that popup, it took 31 seconds for the animation to finish.  They were going faster earlier today, but really I'd just like them to never happen.

I'm using the Desktop Rich Client 4.0 SP7

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Dec 31, 2014 at 05:01 PM

    Hi Matthew,

    I'm not sure what you are referring to when you say animations.  If that window is taking a long time to come up, it is likely the speed/memory available on your system that is slowing it down.  Webi Rich Client is a combination of Java and a C++ application but the client actions are all Java.   So, it is likely that the CPU and memory available to the Java components is depleted. 

    As for turning them off, there is no way that I know of to turn it off.  There may be some way to do it through a Java command line option, but that wouldn't be a "supported" method.

    What is the CPU and RAM of your system?  Did you try using the BILaunchpad Applet designer instead?  That may work better for you.

    Thanks

    Jb

    Add comment
    10|10000 characters needed characters exceeded

    • Can you regedit HKEY_LOCAL_MACHINE\SOFTWARE\SAP BusinessObjects\Suite XI 4.0\default\WebIntelligence\RichClient\JVMOptions\2 to -Xmx1536m and add a new a value -Xincgc. Note that -Xmx1536m varies from desktop machines.  You'd have to fine tune it to find the sweet spot. -Xincgc is to "enable incremental garbage collection." Hope this helps, Jin-Chong