Skip to Content
avatar image
Former Member

Cannot start system, sapstart stucks at starting programs

Hello Experts,

     We have upgraded our kernel version from 7.40 to 7.41, once starting the system using SAP MMC, we found that there are some subnodes that are missing and the system won't startup and does not display the process lists (disp+work, igwrd, etc).

     Also upon checking on the logs, sapstart is stuck on "

     We have also regenerated the SAP service, but the issue still remains

    Hoping for your kind resolution with the issue.

Regards,

Manuel

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • avatar image
    Former Member
    Dec 30, 2014 at 09:37 AM

    Hi,

    Could you share dev_w0,trans.log file for analysis.

    Regards,

    Gaurav

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

           dev_* logs are not updating, only the sapstartsrv, sapstart logs are only updating when starting the system

  • avatar image
    Former Member
    Dec 30, 2014 at 09:42 AM

    Hello Manuel,

    Have you close sapstartsrv.exe before upgrading kernel ? share logs.

    BR,

    K.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 30, 2014 at 09:50 AM

    Hi Manuel,

    follow the below activity.

    - kill all the process related to sap.

    - then restart the services SAP<SID>_<xx>

    - manually run the sapcpe command

    - sapcpe pf=<instance profile of CI/DI/ASCS/SCS>

    Also do paste the sapstartsrv log and dev_w0 , trans.log

    With Regards

    Ashutosh Chaturvedi

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello,

      Please see attached log files

      As for the dev_* logs, I think they are not beneficial as for today since they were not updated after the upgrade, even when starting the system.

      I have started the sapcpe. Here are the logs.

      2014/12/30 03:37:05

      sapcpe version UC: @(#) $Id: //bas/741_REL/src/ccm/sapstart/sapxxcpe.c#4 $ SAP

      Command line:

        0: sapcpe

        1: pf=HC0_DVEBMGS81_SJCT2W-SAP-33

      Trace level (profile): 1

      ** INFO:    Try to find file table sapcpeft (default:sapcpeft)

      ** INFO:    Try to find file table in the central directory \\SJCT2W-SAP-33\sapmnt\HC0\SYS\exe/run\sapcpeft

      ** INFO:    not found any file table.

      *************************************************

      source: \\SJCT2W-SAP-33\sapmnt\HC0\SYS\exe/run

      target: E:\usr\sap\HC0\DVEBMGS81/exe

      *************************************************

      *** ERROR: sapcpe: find <src> \\SJCT2W-SAP-33\sapmnt\HC0\SYS\exe/run failed, 2, No such file or directory, [D:/depot/bas/741_REL/src/ccm/sapstart/sapxxcpe.c:1624]

      trans.txt.zip (12.6 kB)
      dev_w0.txt.zip (2.8 kB)
  • avatar image
    Former Member
    Dec 30, 2014 at 09:51 AM

    Attaching screenshots


    1.png (4.6 kB)
    2.png (6.8 kB)
    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 30, 2014 at 11:08 AM

    Hi,

    *** ERROR => Using non supported HDB version: 1.00.091.00.1418659308

    [dbhdbsql.cpp 119]

    C  *** ERROR => Min. version for this release must be 1.00.17

    Try to have minimum HDB version 1.00.17 as under logs.

    Regards,

    Gaurav

    Add comment
    10|10000 characters needed characters exceeded