Skip to Content
avatar image
Former Member

BO SSO not working using Apache Server as Reverse proxy

Hi,

We have configured SSO on BO and it is working fine. BO deployment is in corporate network. Customer wanted to setup an Apache Server on dmz in order to reach BO system from any network other than corporate one.

We have setup Apache Server as reverse proxy with Tomcat following official SAP notes. This setup working fine with any authentication option on logonNoSso.jsp login page. But when using SSO, Apache Server welcomes user with an authentication box (MS Windows style).After filling username and password (the problem is we don't want to fill any authentication form since we implemented SSO authentication), website does not load any content. We traced the authentication cycle concluding it is successful.

So here are my questions:

  1. Is it possible to use SSO with reversed proxy connection using Apache Server not asking for authentication form?
  2. Do we have to do any further configuration for Apache Server(connecting succesfully to Tomcat on port 8080 not ajp protocol)?

Thanks.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Dec 29, 2014 at 02:09 PM

    Firstly have to create SPN for the rever proxy url.

    Secondly create a browser setting

    Add the url in the Local Internet and go to internet settings->local internet->Custom level

    and select "Automatic logon for current username and password"

    let me know if it fixes your issue.

    Add comment
    10|10000 characters needed characters exceeded