Skip to Content
avatar image
Former Member

Can we delete Number ranges of Vendor (XKN1)

Hello All,

I am shaffe, As I have encountered an error while I am trying to post an vendor invoice (f-43) then it said

IN COMPANYCODE ____ 19 NUMBER RANGE IS MISSING FOR YEAR 2014

so I went back to 'Create vendor number ranges' (xkn1) and I created number ranges with "19" and mistakely given current number is also, and saved it.

Now I could not able to post an invoice of vendor , as I am getting the same above error, and other hand I could not able to delete 19 number range in my company code.

Can anyone provide me solution for this.

Regards,

Shaffe.Shaik

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    avatar image
    Former Member
    Dec 28, 2014 at 03:59 AM

    HI Shaffe,

    You can delete the number range, but before you do that please consider below points:

    1. Vendor already created using number range 19 will still exist in system.

    2. If you try to use same number range again, it will cause in-consistency in database.

    Keeping above points in mind, it is not sugessted to delete number range.

    But if you still feel you need to do that:

    1. Reset the current number to 0. (In Extra menu, you will find option to set current number)

    2. select the number range to be deleted Click in - Sign above to delete number range.

    Hope that helps.

    Pankaj Bansal

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Shaik,

      You are trying to create a no.ranges for vendor master in XKN1. This t.code is used for maintaining no.ranges for vendor master. But your error is telling vendor document no.ranges. You have to create doc.no.ranges in FBN1. So, create a no.range 19 for the year 2014 for the co.code in the t.code.

      Regards,

      Mukthar

  • avatar image
    Former Member
    Dec 28, 2014 at 08:34 AM

    Hi

    Go to FBN1 and create number range in 19 under your CCode

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 29, 2014 at 05:16 AM

    Hi Shaffe

    You might have not saved the Number Ranges.

    To Define Vendor document Types & Number ranges.

    Go to OBA7

    (Navigation:    SPROàSAP Ref IMGàFinancial Accounting (New)àFinancial Accounting

                        Global Settings (New)àDocumentàDocument Typesà Define Document Types for

                        Entry View ( (OBA7)).

    Select Details Button
    Select Number range Information
    Give Company Code XXX (Selece your Company Code)
    Select Change Intervals
    Select Insert Intervals
    No.     Year       From Number       To Number
    19       2014           1900000             1999999
    Press Enter and Save
    Ignore message and press Enter.

    Warm Regards

    Sattaiah Gundu

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 29, 2014 at 08:07 AM

    Hi Shaik,

    Check the Number range 19 belongs which document type in OBA7. Then create required document number range in FBN1.

    Regards

    Gouse

    Add comment
    10|10000 characters needed characters exceeded