Skip to Content

Work Flow Event Linkage Deactivated

Dear Friends,

                   Here i have one situation i.e  usually we did the mail triggering functionality to info record approval. it was working over a year. but today morning itself mail is not triggering . when i check the event trace via SWEL  . its coming like linkage deactivated. we didnt transported any any request and all. for your reference Please go through the below screen shots.

Its is an top most urgent .. Please any one suggest me rectify the Error.

Regards,

Thangam.P

Capture.PNG (12.5 kB)
Capture1.PNG (22.2 kB)
Capture2.PNG (21.0 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Dec 27, 2014 at 08:33 AM

    Hi,

        Solved myself. with help of activating FM

    SWE_EVENT_REC_TYPE_ENABLE

    Regards,

    Thangam.P

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 27, 2014 at 07:19 AM

    Hi,

      Oh dear, you are in a bad situation now because events are not being delivered in Production. Make sure you keep the event trace on so you can see which events are being created.

    The event linkage was deactivated because it encountered an error. This is unfortunately default workflow behaviour, so you should change your event linkage settings as soon as possible.

    To fix it, you may be able to reactivate the linkage via transaction SWE2; otherwise a transport may be required.

    Read this blog on how to stop it happening in future:

    Vanilla is a nasty flavour for #Workflow events or Help my workflows keep getting turned off!

    Good luck!

    Paul

    Add comment
    10|10000 characters needed characters exceeded