Skip to Content
avatar image
Former Member

Spool getting deleted after Abort message

Dear All,

My report is creating spool when I am running in background mode, after message having type E/ S/ W.

But when I change my system message to 'A' '(Abort), the spool is not getting created.

Does the spool fails to generate after abort message?

Thanks & Regards

Akshay

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Dec 25, 2014 at 09:13 AM

    Hi Akshay,

    Read the documentation on Messages in Background jobs:

    • Messages of type "E" and "A" are written to the log. A check is then performed and if applicable, the message is handled with error_message. If this is not the case, the message is also written to the log with message number 564 of the message class 00 and current background processing is interrupted, whereby a message of type "A" executes a database rollback. When the message is processed, background processing is continued.
    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Archana,

      Thanks a lot for your reply. For testing purpose, i have given commit statement before ABORT message. While the spool should contain 2 pages,but only first page is getting generated. Is this happening because of the message?

      Thanks & regards

      Akshay

  • avatar image
    Former Member
    Jan 06, 2015 at 07:38 AM

    Dear All,

    Request you to help me on this issue.

    Spool is getting created with status '+' when i am giving explicit commit before message type A. But only 1st page is getting generated in the spool, while i am expecting 2 pages.

    Thanks & Regards

    Akshay

    Add comment
    10|10000 characters needed characters exceeded